Forums Développement Multimédia

Aller au contenu

cliquez ici pour activer et utiliser ce contrôle

PAO Flash

107 réponses à ce sujet

#1 MisterYo

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 469 messages

Posté 28 March 2006 - 01:44 AM

Bonjour,

la nouvelle mise à jour windows ajoute une nouvelle étape pour tous les visiteurs qui veulent utiliser une fonction de clic ou de rollover sur une animation flash...

savez vous si il existe des solutions (coté integration html) pour desactiver ce message ?
parce que ça pourrit vraiment la navigation...

merci !

Modifié par MisterYo, 28 March 2006 - 01:45 AM.


#2 yohannh

    Ceinture Blanche

  • Members
  • Pip
  • 3 messages

Posté 13 April 2006 - 21:46 PM

Effectivement, c'est franchement énervant!
Je cherche une solution et je vous en fais part si je trouve quelque chose...

Modifié par yohannh, 13 April 2006 - 21:53 PM.


#3 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 13 April 2006 - 22:47 PM

j'ai trouvé une solution avec javascript

http://telflash.free.fr/securite/test.html

http://telflash.free.fr/securite/testjs.html

dite-moi ce que vous pensez du second lien icon_wink.gif

#4 yohannh

    Ceinture Blanche

  • Members
  • Pip
  • 3 messages

Posté 13 April 2006 - 23:54 PM

Brillant!! gourou.gif

#5 dada

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 8510 messages

Posté 14 April 2006 - 10:23 AM

Salut,

ici wink.gif

#6 vangardis

    Ceinture Jaune

  • Members
  • PipPip
  • 16 messages

Posté 14 April 2006 - 11:11 AM

Je commence vraiment à croire que microsoft n'aime pas flash......

#7 vangardis

    Ceinture Jaune

  • Members
  • PipPip
  • 16 messages

Posté 14 April 2006 - 12:13 PM

.

C'est quand même un comble: être obligés d'utiliser 3 tonnes de javascript pour afficher un swf... icon_question.gif quand on pense que certainnes personnes désactivent le js, ça ouvre un bel avenir à flash!!!! icon_exclaim.gif

Très belle initiative des ingénieurs microsoft, vraiment! icon_evil.gif icon_evil.gif

Déja que IE est un navigateur pourri, mais hélas utilisé par la majorité des gens, un navigateur qui ne sait même pas afficher la trensparence des png et qui maintenant ne sait pas afficher "correctement" un swf.....j'espère que cette nouvelle trouvaille finira par le faire couler définitivement!

Mais trève de bavardages.....je sais pas vous, mais moi, le truc proposé par Macromédia (http://www.macromedi.../devletter.html) moi j'arrive pas à le faire marcher.... icon_question.gif icon_question.gif
Déja c'est en anglais et je comprends pas tout...ensuite j'ai essayé de mettre un button1.swf dans le dossier et ça ne l'affiche pas....alors je suis perdu.

Faut dire qu'en plus de tout, moi j'affiche souvent mes swf dans des pages php qui contiennent aussi d'autres choses que mon swf et qui échangent des variables entre php et swf: du coup je peux pas trop me permettre de tout changer comme ça....

Enfin, je voulais savoir pol95 si tu pouvais mettre à disposition ton code qui semble marcher très bien, pour que j'essaye de l'adapter à mon cas.

J'ai regardé la source de ta page mais je ne vois pas à quoi corresponde le "5" dans new FlashObject("test.swf", "fotester", "550", "400", "5", "#ffffff");
J'imagine que le 550 et le 400 sont les dimensions (sauf que moi j'affiche en %) mais je ne vois pas pour le "5"

Je te serais vraiment très très reconnaissant si tu pouvais m'aider à résoudre ce problème microsoftien....

A plus tard j'espère.....

#8 Chahrazad

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 80 messages

Posté 14 April 2006 - 15:04 PM


C'est depuis quand tout ça ? Il faut que j'intègre du javascript dans mes pages et un fichier externe de 8ko (!!!) pour que Internet Explorer n'ajoute pas un bug de plus ?! C'est vraiment du délire...

Déjà qu'il faut passer deux fois plus de temps à corriger les "bugs" de code IE, bientôt en plus il faudra que le site soit deux fois plus lourd... Sans compter les PNG 24bits non-transparents et le reste, microsoft essaye de faire le plus pourri possible ou quoi icon_mad.gif

J'espère qu'il y une solution plus sympathique pour ce problème...



#9 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 14 April 2006 - 17:36 PM

le fichier js externe sert à détecter la version du player, on peut diminuer ça taille, le pb est le même pour les aplets jave, les pdf,... ie c'est de la m....
pour ce qui veule le script vous l'avez en fichier joint

j'ai peur que ça ne dure pas longtemps cette astuce, de toute façon microsoft ne pourra pas maintenir cette mis à jour longtemps, il faut se plaindre

icon_evil.gif

Fichier(s) joint(s)

  • Fichier joint  test.zip   3.07 Ko   832 téléchargement(s)


#10 Chahrazad

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 80 messages

Posté 14 April 2006 - 18:38 PM


Cela ne fonctione pas chez moi, gros bug, je ne sais pas ce qu'est le fameux "5" aussi...

Oui j'espère que bientôt on pourra retirer cette merde.



#11 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 14 April 2006 - 19:18 PM

n.b: le _5 c'est la version du player, pour que ça marche il faut activer javascript

j'ai fait une version plus simple sans détection du player, comme dans l'exemple de macromedia.

Fichier(s) joint(s)

  • Fichier joint  test2.zip   1.27 Ko   1085 téléchargement(s)


#12 jeanphilippe

    Grosso modo

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 30486 messages

Posté 14 April 2006 - 19:20 PM

passez sur OSX icon_confused.gif

#13 jeanphilippe

    Grosso modo

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 30486 messages

Posté 14 April 2006 - 19:20 PM

et surtout , oubliez IE icon_biggrin.gif

#14 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 14 April 2006 - 19:40 PM

c'est pas pour nous, perso j'utilise mozilla firefox mais la plupart des gens utilise ie icon_mrgreen.gif

#15 jeanphilippe

    Grosso modo

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 30486 messages

Posté 14 April 2006 - 19:43 PM

c'est ça qui est dommage icon_confused.gif

#16 Chahrazad

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 80 messages

Posté 14 April 2006 - 19:45 PM


Je n'y arrive toujours pas (j'ai pris test2) icon_confused.gif Je ne me suis jamais servi de java...

Je réessaye encore et encore mais il me bouffe le haut de page (le flash).

La page est valide mais ça marche pas icon_evil.gif

jeanphilippe, c'est parceque les visiteurs utilisent pour la plupart Internet Explorer...

EDIT : Je ne comprends pas ces trois lignes (enfin la dernière) :

<!--URL utilisées dans l'animation-->
<!--texte utilisé dans l'animation-->
<!-- saved from url=(0013)about:internet -->


Modifié par Chahrazad, 14 April 2006 - 19:47 PM.


#17 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 14 April 2006 - 19:55 PM

ça ne sert à rien, c'est flash qui l'insère, tu peux le virer ça n'a aucune incidence
icon_eek.gif

#18 Chahrazad

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 80 messages

Posté 14 April 2006 - 19:59 PM


J'ai déjà essayé en le virant (ou non) mais ça ne marche pas icon_eek.gif

J'ai dans le head : <script type="text/javascript" src="test.js" />

Et dans le body : <script type="text/javascript">RunFoo("files/interface/header.swf", "68", "394", "#ffffff", "header");</script>

Y'a un erreur ? icon_neutral.gif



#19 vangardis

    Ceinture Jaune

  • Members
  • PipPip
  • 16 messages

Posté 14 April 2006 - 20:07 PM

Re-Salut,

Super pour le Js pol95 gourou.gif

J'ai un dernier souci, c'est que j'affiche mon swf dans une page php qui lui passe des variables......

Le code c'est ça.....

<object classid=\"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000\" codebase=\"http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0\" width=\"100%\" height=\"100%\">

<param name=\"movie\" value=\"index.swf\" />
<param name=\"quality\" value=\"high\" />

<param name=\"FlashVars\" value=\"session=<?php echo $mavariable ?>\" />
<embed src=\"index.swf\" FlashVars=\"session=<?php echo $mavariable ?>\" quality=\"high\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\" type=\"application/x-shockwave-flash\" width=\"100%\" height=\"100%\">
</embed>
</object>

J'ai essayé plein de trucs mais j'arrive pas à faire paser ma variable...
Tu crois que tu pourrais faire un truc pour moi? icon_confused.gif

#20 Chahrazad

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 80 messages

Posté 14 April 2006 - 20:11 PM


Je ne connais rien au java moi, ça marche si c'est dans un fichier *.txt que j'inclus dans la page *.php ? icon_rolleyes.gif

Si la réponse est non, que faut-il faire...

Je cherche mais ne voit pas vraiment de cause au fait que cela ne fonctionne pas icon_confused.gif



#21 Chahrazad

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 80 messages

Posté 14 April 2006 - 20:24 PM


C'est bon cela fonctionne, suffisait de pas toucher au truc dans le head...

Réflexe xhtml j'ai coupé le truc et mis un slah icon_redface.gif (pour les meta ça rend invalide je crois).

Enfin bref merci pol95, moins d'1ko c'est bien mieux que 8ko... ça va bien mieux.

smile.gif

EDIT : Quand même bizarre, j'avais pas mis dans le bon ordre la hauteur et largeur du flash dans le body, car dans le fichier *.js c'est marqué en inversé (d'abord hauteur, puis largeur - je n'y connais rien mais c'est étrange).


Modifié par Chahrazad, 14 April 2006 - 20:29 PM.


#22 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 14 April 2006 - 20:46 PM

d'abord c'est pas du java mais du javascript, ça n'a rien à voir

pour ce qui est de flashVars, je ne m'en suis jamais servi mais pour intégrer le script dans php je pense qu'il faut se servir de header()



#23 vangardis

    Ceinture Jaune

  • Members
  • PipPip
  • 16 messages

Posté 15 April 2006 - 10:50 AM

Salut,

Bon, j’ai changé un peu la méthode mais j’ai fini par réussir :
1.Protection IE contre flash contournée (merci pol95 de flash.media-box.net)
2.Passage de variables vers le swf.

Voici la méthode qui fonctionne (jusqu’à la prochaine mer.. de microsoft IE )

Dans le <head> je mets

<script src=\"test.js\" type=\"text/javascript\"></script>
***attention, pour moi c’est dans des fichiers php, d’où les \" ***

A la racine de mon site, un fichier test.js

function RunFoo(swf, hauteur, largeur, couleur, nom, mavariable) {
document.write("<object classid=\"clsid:d27cdb6e-ae6d-11cf-96b8-444553540000\" codebase=\"http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0\" width=\""+hauteur+"\" height=\""+largeur+"\" id=\""+nom+"\" align=\"middle\">\n");
document.write("<param name=\"allowScriptAccess\" value=\"sameDomain\" />\n");
document.write("<param name=\"movie\" value=\""+swf+"\" /><param name=\"quality\" value=\"high\" /><param name=\"bgcolor\" value=\""+couleur+"\" /><param name=\"FlashVars\" value=\"session="+mavariable+"\" /><embed src=\""+swf+"\" FlashVars=\"session="+mavariable+"\" quality=\"high\" bgcolor=\""+couleur+"\" width=\""+hauteur+"\" height=\""+largeur+"\" name=\""+nom+"\" align=\"middle\" allowScriptAccess=\"sameDomain\" type=\"application/x-shockwave-flash\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\" />\n");
document.write("</object>\n");
}


Là où je veux appeler mon swf :

<script type=\"text/javascript\">RunFoo(\"index.swf\", \"100%\", \"100%\", \"#000000\", \"index\", \"$mavariable\");</script>

Ainsi, $mavariable générée plus haut dans le php ($mavariable="arrivee") est reprise sous le nom session (<param name=\"FlashVars\" value=\"session="+mavariable+"\" />) et est bien transmise à mon swf .

Ça marche correctement

Merci à tous pour les conseils divers et variés.

PS (tout ça pour que sur mon site vangardis l'anim d'intro ne soit lue qu'au premier passage sur l'index et pas les autres fois)


#24 ace

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 313 messages

Posté 16 April 2006 - 15:16 PM

Purée, je viens de découvrir la mise à jour d'IE !
C'est à peine croyable !
95% de mes utilisateurs sont sous IE.
On va devoir revoir chaque flash affiché sur tous nos sites, c'est tout simplement abhérent.
Et pour les utilisateus chez qui le javascript n'est pas activé, on fait comment M. Microsoft ?!

#25 Shaoken1327245746

  • Members
  • PipPipPipPipPipPipPipPip
  • 977 messages

Posté 16 April 2006 - 15:22 PM

Salut,

Une meilleure solution pour insérer son SWF via JavaScript est d'utiliser le célèbre FlashObject

Vous aurez en plus une détection efficace de la version de Flash.

++ smile.gif

#26 algeria75

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 242 messages

Posté 16 April 2006 - 15:59 PM

les gars.. je voulait installer firefox justement mais j'ai eu des problemes avec ce dernier.. je sais pas d'ou ça viens..

ben la pluspart du temps la fenetre firefox n'arrete pas de bouger en tremblant verticalement..

quelqu'un saurait d'ou ça viens? icon_sad.gif

#27 jeanalexis38

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 76 messages

Posté 16 April 2006 - 23:23 PM

Bonsoir.
C'est pas du java c'est du javascript.
Pour le passage de variables :

http://blog.deconcept.com/flashobject/
cf. section Passing variables into your movies using the "Flashvars" parameter

Je sais pas si ça répond à ton problème ...

#28 phiphou

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 210 messages

Posté 17 April 2006 - 12:30 PM

C kan meme hallucinant que Microsoft oblige tout le monde à suivre...Si on est obligé de modif toutes ses pages , ça va être relou.

La solution donnée ici fonctionne parfaitement, mais c marrant que Microsoft n'ai pas pensé à un truc pareil. A moins qu'ils ne soient dit : "Ils suivront de toute façons, alors on fait ce qu'on veut".

Enfin, à voir le peu d'interet de Microsoft pour le lecteur Flash, on peut se demander si microsoft ne prépare son propre lecteur.

#29 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 17 April 2006 - 13:33 PM

après vos remarques, j'ai rajouter un petit message au cas où javascript soit désactiver



icon_wink.gif

Fichier(s) joint(s)

  • Fichier joint  test3.zip   677 octets   227 téléchargement(s)


#30 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 17 April 2006 - 13:42 PM

une petite erreur s'est glissée, désolé

Fichier(s) joint(s)

  • Fichier joint  test3.zip   1.12 Ko   905 téléchargement(s)


#31 algeria75

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 242 messages

Posté 17 April 2006 - 14:09 PM

bladesquad (Apr 16 2006, 02:59 PM) a dit :
les gars.. je voulait installer firefox justement mais j'ai eu des problemes avec ce dernier.. je sais pas d'ou ça viens..

ben la pluspart du temps la fenetre firefox n'arrete pas de bouger en tremblant verticalement..

quelqu'un saurait d'ou ça viens?  icon_sad.gif

Voir le message


ok mais bon. quelqu'un peut répondre a ma question svp?

#32 dada

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 8510 messages

Posté 17 April 2006 - 14:18 PM

tu habites au-dessus d'une station de métro ?

icon_biggrin.gif

tu as regardé si tu n'avais pas des spywares ou je ne sais quoi sur ton pc ?

#33 algeria75

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 242 messages

Posté 17 April 2006 - 15:04 PM

c vrais que j'ai pas encore regardé d'ailleurs je suis pas sur mon pc là mais tu pense que c vraiment a cause de ça?

puisque tout le reste marche normal j'ai ça seulement sur firefox en plus je l'ai installé juste après mon dernier formatage de mon disque dur c'est pour ça que je pense pas que c'est a cause de spywares.. icon_confused.gif

#34 dada

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 8510 messages

Posté 17 April 2006 - 15:06 PM

non j'en sais rien en fait, mais je trouve çà tellement bizarre icon_biggrin.gif sinon, pour la station de métro peut-être... wink.gif

#35 algeria75

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 242 messages

Posté 17 April 2006 - 15:53 PM

pfff lol icon_mrgreen.gif

mais sinon a part la station comme t'a dit y a personne d'autre qui aurait le meme probleme ou une solution pour ça? icon_rolleyes.gif

#36 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 17 April 2006 - 20:34 PM

pour ce que ça intéresse, j'ai fait un petit script php qui permet à la page de s'afficher même si le javascript est désactivé

Fichier(s) joint(s)

  • Fichier joint  test4.zip   1.44 Ko   343 téléchargement(s)


#37 Papou88

    Ceinture Blanche

  • Members
  • Pip
  • 1 messages

Posté 18 April 2006 - 12:52 PM

bonjours à tous

J'ai trouvé une solution qui ne satisfait que celui qui la met en pratique.

Les dernière mises à jour de microsoft oblige un clic pour autoriser l'utilisation de flash, plug et autres avant le cli effectif pour lancer le module.

Pour ce qui me concerne j'ai désinstallé la MAJ microsoft KB912812. Bien sûr à la première connexion Microsoft veut réinstaller cette MAJ, il suffit de se mettre en avancée de décocher la MAJ et que la question ne vous soit plus posée.

Maintenant je fonctionne comme avant

Bonne journée


#38 dada

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 8510 messages

Posté 18 April 2006 - 13:06 PM

Salut smile.gif

dans ce cas,si c'est juste pour toi, tu ferais mieux d'installer FireFox icon_biggrin.gif

#39 kadolodai

    Ceinture Blanche

  • Members
  • Pip
  • 1 messages

Posté 18 April 2006 - 14:41 PM

tiens il y a une pub pour une formation flash en dessous...peut etre que chez microsoft ils pourraient s'y mettre...... icon_biggrin.gif

non mais franchement, c'est un scandale....
un Scandale......un scandale
je passe plus de temps à refaire du code à chaque mise à jour d'un tel ou un autre que pour créer des sites.... à croire que les mecs naviguent jamais....
à quand je le demande un bonne vrai mise à jour qui dira à chaque fois que tu vas sur une anim flash.... "Désolé Macromédia n'a pas voulu payer suffisament à microsoft pour que vous puissiez utiliser cette page" ...... icon_eek.gif

enfin voilà, en attendant je vais desactiver la MAJ, merci Papou88...

bien à vous
Kado

#40 dada

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 8510 messages

Posté 18 April 2006 - 14:57 PM

pourquoi retirer cette MAJ ? Cà ne sert à rien. C'est IE qu'il faut retirer ! icon_mrgreen.gif
Installez FireFox, conseillez à votre entourage et à vos clients d'en faire autant ! En plus FireFox a plein de petites qualités qui en font un navigateur agréable à utiliser, au contraire de IE.
Et utilisez le javascript (ou le php) pour intégrer les swf.

#41 service

    Ceinture Jaune

  • Members
  • PipPip
  • 15 messages

Posté 18 April 2006 - 23:02 PM

Simple et qui fonctionne
ICI

J'ai pas lu tous les posts de ce forum et ce lien a peut-être été posté !



#42 cyril.lebret

    Ceinture Blanche

  • Members
  • Pip
  • 1 messages

Posté 18 April 2006 - 23:23 PM

bonsoir

je viens de me rendre compte de la maj : je navigue sur firefox et je viens d'ouvrir ie...

je trouve que c'est vraiment inadmissible, un véritable scandal! J'ai horreur de conseiller tel ou tel explorateur, mais je vais désormais rajouter sur mes sites de télécharger firefox!

Nous devons faire quelquechose! un énorme pourcentage de personnes utilisent IE, un autre pourcentage énorme ne savent meme pas qu'il existe d'autres explorateur!

Faisons quelquechose! Pétitions! Action!

je suis completement démoralisé quand je vois le travail qu'on fourni pour etre acessible par tous, et comment microsoft reduit nos éfforts a néan...

@ bientot

#43 gc_web

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 241 messages

Posté 19 April 2006 - 08:48 AM

pol95 (Apr 13 2006, 08:46 PM) a dit :
j'ai trouvé une solution avec javascript

http://telflash.free.fr/securite/test.html

http://telflash.free.fr/securite/testjs.html

dite-moi ce que vous pensez du second lien


merci à toi pour cette solution. Ca semble marcher parfaitement. smile.gif
Est-ce que quelqu'un sait si ce problème est définitif, ou bien Microsoft prévoit-il de faire quelque chose pour que tout redevienne comme avant ? Sous-entendu, est-ce que c'est bien la peine de refaire tous nos sites ou non ? ....

Modifié par gcworld, 19 April 2006 - 08:49 AM.


#44 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1784 messages

Posté 19 April 2006 - 11:27 AM

il paraît qu'ils ont perdu un procès...

#45 yohannh

    Ceinture Blanche

  • Members
  • Pip
  • 3 messages

Posté 19 April 2006 - 18:06 PM

Vous trouverez ici une autre façon de résoudre ce désagrément.



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)

authorised training centre

Centre de Formation Mediabox - Adobe et Apple Authorised Training Center.

Déclaré auprès de la Direction du Travail et de la Formation Professionnelle

Mediabox : SARL au capital de 62.000€ - Numéro d'activité : 11 75 44555 75 - SIRET : 49371646800035

MEDIABOX, 23, rue de Bruxelles, 75009 PARIS

FFP