Forums Développement Multimédia

Aller au contenu

Flash player detection

PAO Flash

39 réponses à ce sujet

#1 05design

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 223 messages

Posté 07 November 2005 - 12:06 PM

Ras le bol de IE versus Firefox...

Flash Player Detection Kit. c'est de la bombe... sous IE
Flash Player Detection Kit. c'est de la f*** de m*** sous fireFox

Apparement les deux Browsers n'interprète pas vaiment le même JS...

j'ai essayer de trouver des infos en vain..
pour résumé il y a :

FP Detection - Shaoken et
Flash Player Detection Kit

Aucune solution sur FireFox actuellement ? sad.gif



#2 Shaoken1327245746

  • Members
  • PipPipPipPipPipPipPipPip
  • 977 messages

Posté 07 November 2005 - 13:05 PM

Salut,

Que reproches-tu au comportement de FlashObject (qui fait l'objet de mon tuto) sous FireFox ?

J'utilise FireFox comme navigateur principal et je n'ai jamais eu de problème.

++ smile.gif

#3 05design

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 223 messages

Posté 09 November 2005 - 11:37 AM

Ben c'est bien joli tout ça mais il y a un truc que je pige pas ou alors il y a erreur dans mon code :

j'ai donc mes trois fichiers :
- index.swf
- ExpressInstall.as
- flashobject.js
et ma page html :

Code
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>FlashObject-Sample by Shaoken</title>
<script type="text/javascript" src="flashobject.js"></script>
</head>
<body>
<div id="flashcontent">
 contenu Flash
</div>
<script type="text/javascript">
var fo = new FlashObject("index.swf", "index", "236", "134", "8", "#FFF", true);
fo.write("flashcontent");
fo.addVariable("flashVarText", "this is passed in via FlashVars");
</script>
</body>
</html>



Plusieurs soucis :
- Sous IE, la fenetre se ferme... l'utilisateur arrive sur macromedia... pkoi la fenêtre se ferme ?
- Sous firefox, l'utilisateur doit fermer firefox pour que l'install s'achève, puis relancer firefox, pour retaper l'adresse... ??

pas un pour rattraper l'autre..



#4 Shaoken1327245746

  • Members
  • PipPipPipPipPipPipPipPip
  • 977 messages

Posté 09 November 2005 - 11:46 AM

Salut,

Peut-être que ceci et cela t'éclairera.

Sinon n'hésite pas!

++ smile.gif

#5 05design

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 223 messages

Posté 09 November 2005 - 11:47 AM

je viens de supprimer les flash player et module de IE et FF...
et le ce code me dit que j'ai flash... cogne.gif

à l'inverse... le kit de macromédia marche....

#6 05design

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 223 messages

Posté 09 November 2005 - 12:22 PM

j'ai un autre soucis maintenant : je n'arrive plus à supprimer le flash player 8 correctement... cogne.gif cogne.gif cogne.gif
J'en peu plus là !!!!!!

quand je lance un site flash... rien n'apparaît mais quand je lance ma page :
j'ai mon texte "contenu Flash OK"

ras le bol...

#7 Shaoken1327245746

  • Members
  • PipPipPipPipPipPipPipPip
  • 977 messages

Posté 09 November 2005 - 12:49 PM

Etant donné que le texte "contenu Flash OK" est le texte qui doit apparaître lorsque le player n'est pas installé, il est logique que tu le vois.

S'il n'y a qu'une page blanche sur les autres sites, c'est que justement il n'y a peut-être aucune détection du Player.

#8 05design

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 223 messages

Posté 09 November 2005 - 13:52 PM

je n'arrive plus à supprimer le flash player sous IE et FF.....
Comment faire ?

#9 05design

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 223 messages

Posté 09 November 2005 - 14:44 PM

décidement rien ne marche... surtout que je me prends la tête pour des gens qui utilisent firefox.... bref je vais pas rentrer dans ce discours mais

Le kit de detection de macromedia n'est destiné qu'à IE...
Code
new FlashObject("ingni.swf", "ingni", "100%", "100%", "8", "#FFF", true)

ça marche très bien sous IE... pas sous firefox...

là je suis vraiment déséspéré... icon_exclaim.gif

#10 kiroukou

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 2399 messages

Posté 09 November 2005 - 15:00 PM

05design pourrai tu utiliser un ton un petit peu plus agréable dans tests posts ?
Je comprend bien que ton problème t'embète, seulement le ton que tu utilise lors de l'écriture de tes message semble un peu agressif.

Essaie de mieux poser ton problème, en montrant tranquillement, ce qui ne marche pas après des tests complets, pas besoin de poster 10 fois de suite smile.gif
Merci

#11 05design

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 223 messages

Posté 09 November 2005 - 16:16 PM

ennervé.. pas agressif..
encore moins devant Shaoken qui rédige très bien ses explications que ce soit par ses posts ou son blog...

wink.gif



#12 Shaoken1327245746

  • Members
  • PipPipPipPipPipPipPipPip
  • 977 messages

Posté 09 November 2005 - 19:27 PM

Pourrais-tu poster une url ou ajouter un zip du contenu qui pose problème qu'on puisse nous en rendre compte par nous même et surtout voir ce qui cloche ? smile.gif

++ smile.gif

#13 05design

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 223 messages

Posté 10 November 2005 - 12:26 PM

Alors j'ai les fichiers suivants :
- index.swf
- index.html
- flashobject.js

j'arrive plus ou moins à ce que je veux seulement dans ce code :

Code

<script type="text/javascript">
 var version = com.deconcept.FlashObjectUtil.getPlayerVersion();
 if (document.getElementById && (version['major'] > 0)) {
 document.getElementById('flashversion').innerHTML = "FLASH IS OK";
}
</script>


est il possible de mettre mon anim flash à la place de "FLASH IS OK"
j'ai essayé ça mais ça ne fonctionne pas, je suis pas expert en Java...

Code
<script type="text/javascript">
 var fo = new FlashObject("index.swf", "index", "100%", "100%", "8", "#FFF", true);
 var version = com.deconcept.FlashObjectUtil.getPlayerVersion();
 if (document.getElementById && (version['major'] > 0)) {
document.getElementById('flashversion').innerHTML = fo.write("index");;
}
</script>


Merci de ta patience face à ma colère.. mais c bon j'ai pris ma petite pilulle ca matin wink.gif

#14 Shaoken1327245746

  • Members
  • PipPipPipPipPipPipPipPip
  • 977 messages

Posté 11 November 2005 - 14:01 PM

Salut,

Attention, tu ne dois pas taper du code de ce genre à même la page. Cette détection doit se faire d'une manière totalement transparente.

Tu as donc ta page HTML qui doit comporter du code de ce genre:

Html
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>titre de la page</title>

<script type="text/javascript" src="flashobject.js"></script>
 
</head>
<body bgcolor="#ffffff">
 
<div id="flashcontent">
Entre ici le texte que l'utilisateur verra s'il n'a pas le player à jour ou absent.
</div>
 
<script type="text/javascript">
// <![CDATA[
var fo = new FlashObject("tonswf.swf", "FlashObjectSample", "100%", "100%", "8.0.5", "#FFFFFF");
fo.write("flashcontent");
// ]]>
</script>
 
</body>
 
</html>


Dans ce code, deux instructions sont remarquables, dans la balise head:

Html
<script type="text/javascript" src="flashobject.js"></script>


Ce qui inclus le mécanisme de FlashObject à ta page et ensuite, l'intégration même de ton swf plus bas avec

Html
var fo = new FlashObject("tonswf.swf", "FlashObjectSample", "100%", "100%", "8.0.5", "#FFFFFF", false);
fo.write("flashcontent");


Les paremètres sont:

icon_arrow.gif Url de ton SWF
icon_arrow.gif Nom de ton SWF
icon_arrow.gif Largeur de ton SWF
icon_arrow.gif Hauteur de ton SWF
icon_arrow.gif Version minimum que l'utilisateur doit posséder pour voir ton site (sinon il verra le message alternatif)
icon_arrow.gif Couleur de fond
icon_arrow.gif Utilisation de l'ExpressInstall ou pas.

C'est tout, si tu tapes ce code ta détection devrait fonctionner. Penses-bien à placer le fichier FlashObject.js dans le même répertoire que ta page HTML cependant.

++ smile.gif

#15 obi wan

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 402 messages

Posté 12 November 2005 - 20:46 PM

tiens c'est marrant tous vos trucs, moi je résume ma détection de flash 8 à ce ptit bout de code dans un ptit swf que je mets sur la première page du site, et ça fonctionne très bien avec tous les navigateurs :

ActionScript
ouiflash._visible = false;
nonflash._visible = false;
 
if (System.capabilities.version.substr(4,1) != 8) {
nonflash._visible = true;
} else {
ouiflash._visible = true;
}


#16 SetBlue

    Ceinture Blanche

  • Members
  • Pip
  • 12 messages

Posté 14 November 2005 - 14:15 PM

Bonjour,

J'ai lu l'article de Shaoken qui détaille l'utilisation du FlashObject et de la classe expressInstall. Je pense avoir tout fait correctement mais j'ai un léger problème : Je ne peux pas le tester smile.gif

Ben oui, sur le site de MM on ne peut télécharger que la dernière version du flash player (la 8), donc pas moyen de savoir si mon expressInstall fonctionne (evidemment tous mes postes sont équipés du FP8). Pour ça il me faudrait Flash Player 6 ou 7. Connaissez vous un moyen de se procurer les anciennes versions?

Merci d'avance et bravo pour les tutoriaux smile.gif

#17 Shaoken1327245746

  • Members
  • PipPipPipPipPipPipPipPip
  • 977 messages

Posté 14 November 2005 - 14:41 PM

Salut,

Macromedia propose un programme pour désinstaller le Flash Player sur son site. C'est tjs utile pour tester la détection.

Ensuite, pour tester la mise à jour et la version il faut savoir que chaque version de l'IDE posséde un répertoire avec les installs des différents Players. Par exemple, avec MX 2004 tu avais la version 7 du player.

Par défaut les players (plug-in et activeX) se trouvent ici:

[FLASHPATH]\Players

Si tu n'as plus les moyens de réinstaller Flash MX 2004, tu peux tjs me contacter.

++ smile.gif

Modifié par Shaoken, 14 November 2005 - 14:43 PM.


#18 web2mc

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 157 messages

Posté 01 February 2006 - 14:48 PM

Merci Shaoken (et Geoff Stearns bien sur) pour le travail effectuer la dessus.
J'utilise le flashobject depuis un certain temps maintenant pour son integration simple et surtout sa compatibilité au standard.

Mais aujourdhui je me penche sur l'ExpressInstall car je v publier ma premiere anim en flash8...et la gros souci de comprehension de doit dire...

En faite, voila ce qui m'échappe:
je place donc cela en entete de mon anim
"if(ExpressInstall.init())
{
stop();
}

et je publie en flash 8 (car mon anim en utlise les effets).

Mon souci:
je ne vois que le contenu alternatif, et pas de proposition d'installation de flash 8.

Cela me semble normal etant donné que je publie en 8 et que j'ai le player7 d'installer).

en effet si j'utilise le swf "fo_tester.swf" de Geoff Stearns, il me propose d'installer flash8 car ce swf est publier en 7, donc pas de souci, la detection ce fait bien.

mais pour mon cas comment faire? mon anim doit etre publier en 8 et j'aimerai avoir ce petit boutton de Geoff Stearns "Start upgrade" si le player 8 n'est pas installer...

peut-on m'aider?

en esperant avoir été a peu pres clair wink.gif

merci

#19 creaam

    La sève de votre image

  • Members
  • PipPipPipPipPipPipPipPip
  • 588 messages

Posté 16 March 2006 - 23:25 PM

Bonsoir,
J'ai bien suivi les explications de Shaoken (explication limpide) mais cela ne fonctionne pas, pas comme je l'ai compris en tout cas.
Normalement cela doit détecter et proposé l'installation ou la mise à jour du player à l'utilisateur ?
Ben moi ce n'est pas ce qu'il se passe.
En faisant comme Shaoken, j'ai le texte alternatif qui s'affiche bien mais pas de swf qui propose l'installation du player.
Et en cliquant sur ce lien
Code
<a href="expressinstall.html?detectflash=false">
sur IE, l'anime ce lance mais y a pas de FP8 qui s'installe.
Sur FF, c'est la même chose sauf que si je clic sur le lien il me demande d'installer le plugin flash player, comme si il n'y avait pas de flashobject.
Voici mon code HTML :

Code
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>titre de la page</title>
<link type="text/css" rel="stylesheet" href="style.css" title="styles" />
<script type="text/javascript" src="flashobject.js"></script>

</head>
<body>

<div id="flashcontent">
Ceci est remplacé par votre contenu Flash.
Placez ici votre contenu alternatif et les utilisateurs sans le Flash plugin ou avec Javascript désactivé le verront.
Placez un lien vers <a href="votrepage.htm?detectflash=false">votre page</a> pour passer outre la détection si vous le désirez.
</div>
<script type="text/javascript">
// <![CDATA[
 
var fo = new FlashObject("animation.swf", "animation", "811", "196", "8.0.5", "#FF6600", true);
fo.write("flashcontent");
 
// ]]>
</script>


Et voici sur la 1ère frame de mon fla :

Code
if (ExpressInstall.init()) {
   stop();
}


Voici le lien de la page qui contient tout cela.

Merci par avance de votre aide.

www.creaam.com

#20 creaam

    La sève de votre image

  • Members
  • PipPipPipPipPipPipPipPip
  • 588 messages

Posté 19 March 2006 - 14:13 PM

Je viens tout juste de résoudre mon PB.
En faite cela venait de mon fichier flash, il fallait mette le texte et le bouton dans la bibliothèque pour mettre à jour le player. Je viens de faire le teste sur IE et FF et ça marche nickel.
www.creaam.com

#21 dlorge

    Ceinture Jaune

  • Members
  • PipPip
  • 17 messages

Posté 16 May 2006 - 15:26 PM

salut,

merci pour tous ces précieux conseils, mais je préfère arrêter car j'ai tout bien fait comme indiqué mais ça ne fonctionne pas du tout de mon côté.


Je me demande juste ce que Flashtout a voulu dire par "mettre e bouton et le texte dans la biblio", car il semblerait que j'en suis au même point que tu ne l'étais avant de faire...

si le thread n'est pas trop enterré...

a+

#22 creaam

    La sève de votre image

  • Members
  • PipPipPipPipPipPipPipPip
  • 588 messages

Posté 16 May 2006 - 19:37 PM

Je fini m'a grillade et je vais tenter de te expliqué comment j'ai fais. icon_wink.gif
www.creaam.com

#23 jeanphilippe

    Grosso modo

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 30486 messages

Posté 16 May 2006 - 19:39 PM

ou lire cela : http://jeanphiblog.media-box.net/dotclear/...-with-swfobject

#24 creaam

    La sève de votre image

  • Members
  • PipPipPipPipPipPipPipPip
  • 588 messages

Posté 16 May 2006 - 22:29 PM

En faite il faut que tu ouvre le fla que tu as téléchargé sur le site de Geoff Stearns qui se nomme "so_tester.fla", dans la bibliothèque de ce fla tu as un clip qui se nomme "upgrade message" tu le fait glissé sur ton fla à toi pour l'avoir dans ta biblio, et en suite tu ouvre ce clip et tu change le texte qui ce trouve dans le clip pour l'adapter à tes besoins (ce texte explique que "vous ne possédez pas la bonne version du FP").
En faite le truc est simple car si "swfobject_source" (c'est comme ça qu'il s'appel maintenant) détecte un FP inférieur à 8 il exécute ce code qui est commenter en anglais.

ActionScript
var ExpressInstall = new ExpressInstall();
 
if (ExpressInstall.needsUpdate) {

var upgradeMsg = _root.attachMovie("upgradeMsg_src", "upgradeMsg", 1);
upgradeMsg._x = Stage.width / 2;
upgradeMsg._y = Stage.height / 2;

upgradeMsg.upgradeBtn.onRelease = function() {
ExpressInstall.init();
}
stop();
}

voilà tout, j'espère que cela va t'aider.

www.creaam.com

#25 ktxjunior

    Ceinture Blanche

  • Members
  • Pip
  • 1 messages

Posté 17 May 2006 - 07:31 AM

le bonjour à vous tous,
J'ai également quelques soucis avec le code de shaoken (excellent article d'ailleurs).
Je m'explique, j'ai inséré le code sans l'express install et ai supprimer le player flash.
Je teste, tout fonctionne le message d erreur apparait me disant que je dois avoir au moins la version 8 et me renvois vers le site macromedia pour l install.

Je fais donc la mise à jour pour mozilla, aucun probleme le site marche, par contre sous IE rien a faire, j'ai beau installer le plug in il ne me detecte pas que celui ci ets supérieur à la version 8 et donc me renvois vers le message d erreur.
Le test me confirme bien que la versione ts la 8.0.24.0

Si quelqu'un peut m'expliquer d ou vient ce phénomène je lui en serais extrêmement reconnaissant

#26 capou

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 145 messages

Posté 08 August 2006 - 13:48 PM

Un tout grand merci à Shaoken pour ses explications.

il me reste un petit soucis comment mettre comme paramètre un fond transparent avec ce code ?

var fo = new FlashObject("tonswf.swf", "FlashObjectSample", "100%", "100%", "8.0.5", "#FFFFFF", false);

à la place de #FFFFFF, j'ai essayé transparent, wmode=transparent comme avant mais rien n'y fait ?



#27 capou

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 145 messages

Posté 08 August 2006 - 14:09 PM

J'ai trouvé, je place ici la réponse ça pourra peut être aider quelqu'un autre, suffit de mettre en dessous de la ligne:

fo.addParam("wmode", "transparent");



#28 contact

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 30 October 2006 - 16:30 PM

pour ceux qui veulent faire des tests de detection :

vous avez les méthodes de désinstallation : ICI

et les anciens Player Flash en téléchargement : ICI

Modifié par Le Comte, 30 October 2006 - 16:31 PM.


#29 contact

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 30 October 2006 - 19:44 PM

re-bonjour, icon_smile.gif

alors par contre j'aimerais comprendre quelque chose,
sur la méthode SWFObject 1.4,

quand je test la detection fournit dans le zip :
et apres avoir désinstallé Fp de mon Pc,
je lance donc le fichier "expressinstall.html" car c'est cette méthode à priori qui m'intéresserait,
évitant de rediriger le surfeur sur la page de mise à jour d'Adobe,

j'ai bien le message de remplacement qui dit que "la version de flash doit etre upgradé (en anglais)"
mais rien ne se passe ! (le fameux btn et message n'appararaissent pas)

si quelqu'un avait une url avec ce systeme d'installé pour que j'aille tester,
je suis preneur icon_biggrin.gif

merci

Modifié par Le Comte, 30 October 2006 - 19:45 PM.


#30 contact

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 31 October 2006 - 14:00 PM

toujours sur le sujet des détections,
je viens de découvrir que l'on pouvait désactiver le module Flash dans IE,
tres utile pour tester son petit "détecteur de FLash" sans s'embeter à désinstaller/réinstaller...

suffit d'aller dans "outils" > "Gérer les modules complémentaires"

là vous aurez deux listes déroulantes :
- les modules complémentaires actuellement chargés dans IE
- les modules complémentaires qui ont deja été utilisés dans IE

suffit de selectionner le module "Flash shockwave Objet", puis de désactiver l'activeX
grace au menu contextuel du bas ...
d'ailleurs on peut voir quel fichier est utilisé, exemple pour Fp9 > "Flash9.ocx"

> apres cette parenthese,
je visite donc plein de sites Flash, et je ne trouve toujours pas de sites
utilisant l'express install...
pour la plupart, ils affichent un message personnalisé de detection
mais redirige sur le site d'Adobe pour télécharger le module...

Modifié par Le Comte, 31 October 2006 - 14:01 PM.


#31 contact

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 31 October 2006 - 14:37 PM

dernier post icon_biggrin.gif , j'arrete de monologuer...

finalement je me rends compte que la plupart des sites Flash (les 2/3 on va dire)
n'ont aucune détection...

> ce qui amene au visiteur qui n'ont pas le lecteur Flash, une image "morte" pour IE,
apres pour Firefox, le plugin est proposé automatiquement...
vous allez me dire que 99% des visiteurs ont flash dans leur navigateur favoris...

> mais quel est le pourcentage des visiteurs qui ont le dernier FP ?
dans ce cas, les 2/3 des sites dont je parle s'afficheront avec une vieille version FP,
mais comment ? bug de flash en tout genre ? anim et menus qui ne fonctionnent pas ?

conclusion :
merci Internet Explorer pour vos superbes innovations,
c'est nous les designers et codeurs qui en patissont,
on se creuse la tête et perdont du temps pourquoi ? on se le demande bien...
ce serait quand meme pas difficile de faire comme Firefox et de suivre ce bon exemple...

enfin...

#32 creaam

    La sève de votre image

  • Members
  • PipPipPipPipPipPipPipPip
  • 588 messages

Posté 31 October 2006 - 17:21 PM

Salut,

Je ne vois pas le problème que vous avez avec FlashObjet, moi je l'utilise et ça marche très bien, sur IE comme sur FF.

Voici un site sur le quel j'utilise cette méthode.

http://www.asso-creatique.com

Normalement avec tout ce qui a été dit dans ce post vous devez vous en sortir sans soucis.

@ ++

www.creaam.com

#33 contact

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 31 October 2006 - 17:40 PM

ok..je ne suis pas certain de tout saisir alors ...

CITATION
Association Créatique, Compagnie de danse HIP-HOP
Vous ne possédez pas le Flash Player
Ce site est en flash. Si vous lisez ce texte c'est que vous ne possédez pas le lecteur flash player. Nous vous invitons à le télécharger sur le site de l'auteur, (macromedia). Vous pouvez en cliquant sur ce lien faire une détection du lecteur.


voila donc ce que tu affiches quand il y a un problème avec le Fp...
tout ca je l'ai bien saisi...

> tu renvoi vers le site de Macromedia sur une page de download
(d'ailleurs en passant, tu devrais pointer direct sur le lecteur Flash)...
yen a plein qui vont lacher l'affaire...enfin c'est mon point de vue
je ne peux pas me permettre avec certains clients...
> et quand je clique sur "le lien faire une detection", ca me renvoie sur l'index


j'avais compris que l'express install servait justement à installer ou updater le Fp
sans aller sur le site de Macromédia....

ou alors j'ai mal compris ? rassure moi icon_biggrin.gif

Modifié par Le Comte, 31 October 2006 - 17:42 PM.


#34 creaam

    La sève de votre image

  • Members
  • PipPipPipPipPipPipPipPip
  • 588 messages

Posté 31 October 2006 - 19:48 PM

Ha oui, effectivement. Si tu n'a pas de FP sur ton ordi, c'est le texte html par défaut qui s'affiche, et là tu mets ce que tu veux en proposant aux visiteurs d’installer le FP. La détection c'est normalement au cas ou le FP est désactivé ou pas pris en compte par le navigateur (j’ai eu ce problème avec IE, j’avais bien le FP, mais IE ne le voyer pas). Mais pour moi le gros avantage de FlashObjet, c'est la mise à jour du FP, si par exemple tu as sur ta machine le FP 7, et que tu as fais ton anime avec Flash 8, ben là tu as un SWF qui s'affiche et qui te propose de mettre à jour ton FP sans passé par le site adobe. Aux lieux de jouer ton anime avec la moitié des effets et qui ne ressemble à rien.
Et en plus cette méthode d'intégration du swf dans HTML est valide W3C.

CITATION
j'avais compris que l'express install servait justement à installer ou updater le Fp
sans aller sur le site de Macromédia....
ou alors j'ai mal compris ? rassure moi


Tu as mal compris icon_lol.gif
Tu ne peu pas faire installer le FP de force à un visiteur, ce n’est pas une bonne chose. Là, tu lui laisse le choix de faire lui-même l’instal.
Par contre comme je t’ai dit plus haut, pour la mise à jour de FP, tu ne passe pas par le site Adobe.

CITATION
(d'ailleurs en passant, tu devrais pointer direct sur le lecteur Flash)...


Oui, je ne l’avais pas encore fini ce lui là, en plus je crois qu’il y a des fautes d’orthographe sur le texte HTML. Le site entier n'est pas fini de toute façon.

Voilà j'espère que cela va t'aider.



www.creaam.com

#35 contact

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 31 October 2006 - 22:21 PM

ok j'avais pas bien saisi en effet icon_biggrin.gif
désolé si je ne comprends pas vite...

j'ai fait des essais avec Fp 5.0.30 puis Fp 6.0.29 (ie)
je n'ai jamais pu faire la MAJ en interne avec l'express install
du ficher ZIP fourni avec le kit SWFobject.

merci pour tes réponses en tout cas,
j'ai bien avancé...

à force de vouloir simplifier la vie des internautes,
on finit par se compliquer la sienne...
l'express install in my dream... icon_biggrin.gif






#36 creaam

    La sève de votre image

  • Members
  • PipPipPipPipPipPipPipPip
  • 588 messages

Posté 31 October 2006 - 22:27 PM

CITATION
je n'ai jamais pu faire la MAJ en interne avec l'express install

Tu veux dire en local ?
Il me semble que ça ne marche qu'en ligne
www.creaam.com

#37 contact

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 31 October 2006 - 22:39 PM

oui pour l'essai de l'express install pur, c'était en local

pour tous les sites que j'ai testé (une trentaine), toujours avec le Fp5 ou 6,
tous m'ont renvoyé sur le site d'adobe, ils ont bien un detect flash perso,
avec texte de remplacement,
mais personne n'a d' express install, un lien de téléchargement seulement...

j'ai rencontré aussi quelques plantages d'IE
sur des pages de detection icon_lol.gif (avec le Fp5 et Fp6 aussi)


j'ai aussi fait des tests avec les scripts d'IE désactivés,
mais avec le Fp9 cette fois-ci,
pour voir comment réagi le detect flash

> pour ton site asso-creatique.com, ca bloque la visite du site carément... icon_confused.gif
> par contre pour tous les autres sites que j'ai visité, en général
ni vu ni connu...

Modifié par Le Comte, 31 October 2006 - 22:43 PM.


#38 creaam

    La sève de votre image

  • Members
  • PipPipPipPipPipPipPipPip
  • 588 messages

Posté 31 October 2006 - 23:00 PM

CITATION
pour ton site asso-creatique.com, ca bloque la visite du site carément...

Je viens de faire le teste, et il me dit juste que l'Activex Flash shockwave Objet est désactiver, je l'active et ça marche sans PB.

www.creaam.com

#39 contact

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 01 November 2006 - 00:45 AM

non je parlais des scripts (java, javascripts) désactivés...
mais passons, ca ne représente que tres peu de monde...

#40 d.lartigue

    Ceinture Verte

  • Members
  • PipPipPipPip
  • 65 messages

Posté 09 March 2007 - 10:40 AM

bon, moi tout fonctionne, l'express install, détection du flash player, etc... avec l'excellent tuto de deconcept.
Seulement une fois que la bonne version de flash player est installée j'aimerais qu'automatiquement on soit redirigé sur la bonne page qui contient le site complet. Pourquoi ne pas le mettre directement dans l'index d'expressinstall ? simplement parce que ma page qui contient le swf du site internet contient des balises div bien spécifique pour l'affichage et l'ajustement par rapport aux différents écrans. Je ne suis pas assez doué pour mélanger le code du swfobject dans ma page qui contient mon swf complet. deconcept propose un paramètre: xiRedirectUrl, j'ai essayé de le placer comme il le précise, mais cela ne focntionne pas... est-ce que quelqu'un pourrait m'aider svp ?

mille merci d'avance



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)

authorised training centre

Centre de Formation Mediabox - Adobe et Apple Authorised Training Center.

Déclaré auprès de la Direction du Travail et de la Formation Professionnelle

Mediabox : SARL au capital de 62.000€ - Numéro d'activité : 11 75 44555 75 - SIRET : 49371646800035

MEDIABOX, 23, rue de Bruxelles, 75009 PARIS

FFP