Forums Développement Multimédia

Aller au contenu

Comment modifier son url ?

CODE HTML CSS

12 réponses à ce sujet

#1 Howahkan

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 29 May 2011 - 20:35 PM

Bonjour !

Je vous explique mon petit problème.
Voici mon site : http://fabienvervenne.be.
J'aimerais le renommer comme ceci : fabienvervenne.be/blog/ ou autrement à la limite mais il faut que blog y soit.

Et le truc qu'il me faut :
Garder le nom fabienvervenne.be et en modifier le design.
Et garder le site/blog actuel et le renommer fabienvervenne.be/blog/


Je sais pas si je suis très clair ^^
Est-ce possible ? Est-ce que je dois racheter un nom de domaine ou payer une modification ?
Que puis-je faire avec comme base mon site/blog ?

P.S. : Je suis sous OVH

Merci à vous !

Modifié par Howahkan, 29 May 2011 - 20:36 PM.


#2 ikyo

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 2442 messages

Posté 30 May 2011 - 06:12 AM

Bonjour Howahkan,

Ton nom de domaine est fabienvervenne.be
Ce qu'il y a après tient de ton adresse, de ton chemin ta redirection, mais n'est plus le fait de ton registar.

Je connais mal l'espace d'admin d'ovh que je trouve assez confus. A priori cela peut également se régler avec le .htaccess ou dans Accueil > Mutualisé > Domaines & DNS > Zone DNS (aller dans le manageur de OVH, créer un nouveau domaine dans "multi-domaines" et choisir le répertoire de destination).

Pourquoi veux-tu que cela pointe vers "blog" spécifiquement ?
Il vaudrait mieux (pour ton référencement) que cela pointe vers la catégorie de ton article puis un nom de page
Mais ton site peut ne pas avoir tous ces éléments.

Pas besoin en tout cas de redirection 301 (pour ne pas perdre ton référencement) si ton site est tout neuf ou non constitué.

#3 Howahkan

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 30 May 2011 - 10:21 AM

Merci :mrgreen:

Ce que je voulais et que je veux toujours, c'est mon blog (avec le design qu'avait fabienvervenne.be) en le renommant autrement (avec blog dedans) ET fabienvervenne.be sous forme de site Cargo.

Je m'y connais pas trop là-dedans... j'irai voir dans multi-domaine ce que je peux faire. Je vais essayer de trouvé un tutoriel.

Mais je crois que c'est cuit, car hier soir, je suis allé dans le DNS et j'ai modifié l'IP pour la diriger vers Cargo (un wordpress à l'américaine) et depuis, j'attends l'éditeur (il faut 24h pour son envoi après demande).

Et depuis, mon blog a disparu. Quand j'ai tenté de remettre le dns avec l'ip de base, il revient pas.
Je crois que j'ai pomé mon blog ! (j'avais fait une sauvegarde filezilla avant mais bon...)

#4 Howahkan

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 30 May 2011 - 10:43 AM

Voilà mes DNS si tu veux jeter un coup d'oeil : http://img11.hosting....a768112905.png J'ai créé un sous-domaine blog.fabienvervenne.be

Est-ce que si je remet l'IP de base à blog.fabienvervenne.be, mon site reviendra (sous blog.fabienvervenne.be) ?
Et laisser la nouvelle IP de Cargo à fabienvervenne.be pour avoir accès à Cargo d'ici quelques heures.

Ca pourrait aller ? J'aurais donc mon blog de base sous blog.fabienvervenne.be et mon site à construire avec Cargo sous fabienvervenne.be (tant pis pour le référencement à la limite...)

Modifié par Howahkan, 30 May 2011 - 10:45 AM.


#5 ikyo

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 2442 messages

Posté 30 May 2011 - 12:53 PM

L'image que tu joins n'est pas visible...il y a un souci dans l'adresse
Autrement ton option me semble la bonne...Enfin si je comprends bien

Si d'autres connaissent mieux (que moi) le système d'OVH...Leur témoignage est bienvenu
Chez mon hébergeur (pourtant pas parfait) les modifs se font dans un délai de la minute à l'heure, mais jamais sur 24h !

#6 Eddy.vh

    Éternel apprenti.

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 1194 messages

Posté 30 May 2011 - 16:06 PM

Bonjour.
Je suis chez OVH.
Déjà, j'ai le sentiment, que lorsqu'on va titiller les ip, faut s'y connaitre sinon, on s'abstient. Je dirai que là c'est tout à fait normal que ton site ait disparu. Je n'ai jamais joué avec les IP et ne sais si ton site reviendra sous une nouvelle IP :mrgreen:
Les modifications dans l'admin d'OVH prennent parfois jusqu'à 24.00h pour être prise en compte, mais j'ai l'impression que c'est surtout une annonce avec un temps maximal, bien souvent, les changements sont plus rapides.

Pour l'adresse http://monsite.be/blog, il faudrait que le domaine cible le répertoire www/, que dans ce répertoire, tu ais un sous-répertoire nommé "blog" et qu'il contienne ton blog.
Sinon, l'idée du sous domaine, est je pense ce qui te conviendra le mieux. Pense aussi lors de la création d'un domaine ou un sous-domaine de créer ceolui qui prend le www devant, je trouve cela plus convivial.

#7 Howahkan

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 31 May 2011 - 09:27 AM

Merci pour vous réponses !

Revoici un print : http://img863.images...8520/pagevf.jpg

La redirection s'est bien passée. En modifiant l'ip de fabienvervenne.be (173.203.204.123 pour CARGO). Mon site s'affiche maintenant sous sa nouvelle forme.

Mais maintenant, j'aimerais récupérer mon blog d'avant (tout les fichiers sont encore sur le serveur avec Filezilla).
J'ai remis l'ip de base (213.186.33.19) sous blog.fabienvervenne.be mais quand j'ouvre le lien : not found.

Comment faire pour récupérer la fonctionnalité de l'ancien fabienvervenne.be sous blog.fabienvervenne.be ?
Où dois-je faire les changements ?

#8 Eddy.vh

    Éternel apprenti.

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 1194 messages

Posté 01 June 2011 - 13:14 PM

Bonjour.
Dans quel répertoire se trouve le blog sur ton espace OVH ? As-tu bien dirigé le domaine vers ce répertoire ? S'agit-il bien du sous-domaine que tu as créé ? Y avais-tu apporté aussi un changement d'IP ?

#9 Howahkan

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 01 June 2011 - 14:49 PM

J'ai qu'un répertoire je pense, c'est fabienvervenne.be

Avant quand j'allais sur mon wordpress, je passais par là http://fabienvervenne.be//wp-login.php
Mais vu que j'ai modifié le DNS, maintenant, même cette adresse va vers mon nouveau site.

Comment faire la redirection ? Je suis franchement perdu. Sorry si j'apporte pas beaucoup de réponses à tes questions, je m'y connais vraiment pas dans le domaine...

En gros, j'aimerais juste retourner sous mon éditeur wordpress avec cette adresse là : blog.fabienvervenne.be. En ce moment sur http://blog.fabienvervenne.be/, y a rien en tout cas.

Modifié par Howahkan, 01 June 2011 - 14:50 PM.


#10 Howahkan

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 01 June 2011 - 18:46 PM

J'ai "pseudo récupéré" mon site suite à une redirection mais comment faire pour le régler à nouveau comme avant ?
Le voici : http://blog.fabienvervenne.be/ (sous wordpress)

Dans filezilla, j'ai glisser tout dans www/blog/

#11 matt-murdock

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 6851 messages

Posté 01 June 2011 - 19:40 PM

tu peut pas vraiment faire cela ... car tout tes chemins interne au blog sont faux...

vas falloir reinstaller d abord un blog vide et essayer de migrer le contenu apres...

#12 Eddy.vh

    Éternel apprenti.

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 1194 messages

Posté 02 June 2011 - 13:01 PM

Essaye d'être bien clair dans tes explications.

Tu as créé un sous-domaine "blog.fabienvervenne.be", tu as dirigé je suppose ce sous-domaine vers le répertoire blog qui se trouve dans le répertoire www de ton espace OVH.

Aussi tu dis ne pas trop t'y connaitre mais tu joues avec les DNS et IP ??? c'est un peu et même bien osé !!! Je te conseille, via ton administration, de contacter le service d'assistance d'OVH, ils sont très réacifs et compétents. Ils résolvent en général très vite ce genre de soucis ou en tous cas t’expliquent, si tu peux le faire toi-même, comment t'y prendre pour retrouver un environnement sain.

Lors de ton contact, explique-leur bien tout ce que tu as fait, même les "bêtises" (changement d'IP, etc.) afin qu'ils savent sur quoi ils doivent se baser pour leur recherche et leur réponses. Je suis sur qu'ils viendront à bout de ce soucis rapidement.

#13 Howahkan

    Ceinture Jaune

  • Members
  • PipPip
  • 18 messages

Posté 03 June 2011 - 11:44 AM

J'ai finalement réussi à faire ce que je désirais, j'ai bien dut réinstallé un blog. Pour se faire, j'ai vider mon ftp et j'ai réinstallé wordpress dans www/blog. Là, j'ai eu de nouveau accès à mon admin wordpress.

Ensuite, j'ai glissé mon theme dans www/blog/wp-contents/themes. Et là, paf ! Mon blog est revenu ! Vide d'articles bien entendu, mais la structure travaillée au préalable est bien présente. Donc, je remet tout à jour en réimportant les articles un à un, etc.

Et là, autre problème :

• Je veux rajouter un lien sur le côté dans 'to find' me. Pour se faire, je vais dans les modèles comme je faisais avat, dans colonne latérale (sidebar.php), et là, je pige pas trop. C'était assez brouillon ! y avait plus rien de propre. Donc, je décide de faire un test, reprendre une ancienne sauvegarde du code et la coller. Je le fait, pas de changement, rien de grave donc. Là, je rajoute un lien : <li><a href="http://www.fabienvervenne.be" title="Official website" target=blank>www.fabienvervenne.be</a></li>

Et ca fonctionne pas ! il n'apparait pas. J'ai même essayer de supprimer un autre... et quand je retourne dans mon site, il disparait pas non plus. Comme si tout était figé à ce niveau là (to find me et friends).

Comment faire ?

Modifié par Howahkan, 03 June 2011 - 11:45 AM.




1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)

authorised training centre

Centre de Formation Mediabox - Adobe et Apple Authorised Training Center.

Déclaré auprès de la Direction du Travail et de la Formation Professionnelle

Mediabox : SARL au capital de 62.000€ - Numéro d'activité : 11 75 44555 75 - SIRET : 49371646800035

MEDIABOX, 23, rue de Bruxelles, 75009 PARIS

FFP