Forums Développement Multimédia

Aller au contenu

Problème de typo crénelée sur AE CS4 sur PC

VIDEO After Effects

12 réponses à ce sujet

#1 freenetstef

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 173 messages

Posté 02 juillet 2010 - 13:25

salut la compagnie,

j'ai un gros souci de typo crénelée sur AE CS4 sur un PC

Existe-t-il des problèmes connus et répertoriés avec After Effects CS4 sur PC (Windows XP), mes typos sortent crénelées sur leurs contours dans tous mes rendus, même non compressés ???

Y-a-t-il des paramètres spécifiques à prendre en compte et régler pour optimiser le lissage des typos en sortie ?

Pour gagner du temps, je vous livre les réponses déjà faites sur un autre forum :


* * * as-tu essayé avec différentes polices de caractères ? même résultat ?
oui, c'est ça qui est bizarre

moi je viens du mac, et justement, j'ai tjs trouvé que le lissage des polices sur le pc,
c'était pas au point, là du coup, je me pose la question, à côté de cela, j'ai remarqué qu'avec
After Effects CS3 sous mac, le lissage des typos n'était pas non plus tjs optimum, mais rien à voir avec ce que j'obtiens là et qui fout presque 6mn de clip à la poubelle !

C'est pour cette raison, que je précise bosser avec la CS4 sous Win XP et avec FontAgent Pro 4

Donc, me manquerait-il un utilitaire extérieur à AE pour lisser les polices ?

Au passage, je me demande si tout le monde rencontre ce genre de problème d'aliasing sur les polices avec AE et en particulier avec AE CS4 !?


* * * rendu entrelacé ou progressif ?
progressif, c'est pour une diffusion sur youtube


* * * dans ton rendu, as-tu bien choisie la qualité optimum ?
oui


* * * est-ce que ta police est bien reconnue par ton système ?
ben voui, enfin, en tout cas elle est présente ds le menu police d'After, ça suffit pas ???


* * * quand tu travailles avec la police dans ta fenêtre de composition, est-ce que le crénelage apparaît déjà ?
Et........... oui....... Bingo !

Je pensais qu'il existait des paramêtres et autres cases à cocher comme ds toshop pr forcer le lissage des typos,
mais si ils existent, je n'ai point trouvé !


* * * tu ne nous dit pas dans quel format tu travailles : SD, HD ?... pixels carrées ou rectangulaire ?
640 X 360 px - en pixels carrés

typo utilisée : helvetica roman et/ou helvetica Neue LT roman

rendu : quicktime en H.264 et/ou rendu quicktime non compressé, le problème reste le même


* * * à quoi ressemble tes polices lorsque tu les utilises dans Illustrator ou Photoshop ? normale ?
la même, crénelée..... damned'


* * * as-tu essayer de ré-initialiser les préférences d' After Effects ?
oui, ça change rien



malheureusement, j'ai vraiment l'impression que le problème vient du PC, car j'ai tout testé, et j'ai rien de mieux c'est idem ds illustrator, photoshop, la typo est tout aussi crénelée et importée ds AE derrière, cela reste bien évidemment aussi moche

(le bouton de "continuous rasterization" (le terme français m'échappe à l'instant même) enclenché of course ;-)

Le pire c'est qu'il s'agit d'un helvetica de base, d'ailleurs j'ai essayé avec les différents helvetica que je possède, ça change rien


J'ai remarqué un truc, certaines polices sont mieux anti-aliasées que d'autres, mais par exemple, l'arial est tout aussi crénelée.

Le truc, c'est que apparemment cela le fait moins dans des très grandes tailles de caractères

Quelqu'un saura-t-il me dire s'il me manque un outil, un utilitaire qui pallie, gére ce problème de lissage des polices à l'écran ???

Sinon, je n'ai pas encore eu la possibilité de tester mon fichier AE sur une version mac, mais je suis convaincu que le problème serait réglé de lui-même.

Fichier(s) joint(s)



#2 couad

  • Members
  • PipPipPipPipPipPipPipPip
  • 1 002 messages

Posté 02 juillet 2010 - 20:42

Hello Netstef,

Si ça le fait sur tous les logiciels Adobe, c'est à première vue que c'est soit ta typo qui déconne, soit c'est hardware.
En plus de 10 ans d'After, je n'ai jamais eu un seul problème de crènelage de typo lié à After Effects. Et pourtant, j'en ai écumé des typos pourries et des ordinateurs pourris ;-). Il y a des typos qui sont effectivement mieux antialisées que d'autres, mais c'est dû à la typo elle-même, pas à After.
C'est toujours la typo qui était en cause, ou un traitement particulier dessus qui faisait apparaitre un crènelage (du genre un coup de niveaux à fond après avoir mis du glow, de la satu, etc...)

Zippes ta typo, et mets la à dispo. Je ferai un test pour te dire si ca fonctionne sur mon mac et mon PC.
Idem pour ton fichier After si tu le peux. En version allégée bien sûr. Pas besoin de tous tes médias, seule tes typos comptent.

#3 freenetstef

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 173 messages

Posté 03 juillet 2010 - 12:18

c'est sûr, j'ai plutôt tendance à aller ds le meme sens que toi, à savoir, la typo est responsable


bien souvent qd tu tombes (tombais) sur un os en production en agence, particulièrement en pao la typo est la graresponsable


écoute, je vais te préparer un petit packagesimplifié piur que tu puisse svoir sur une autre machine

le problème est que monma cm'a lâché et je n'ai plus que le pc pour bosser, et otu plein d'allergies qui vont avec

en tout cas, merci déjà de ta propositon det de me file run cop demain là-dessus

#4 freenetstef

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 173 messages

Posté 03 juillet 2010 - 12:32

désolé le post est parti tout seul (ou presque ;-) ) sans que je puisse corriger les fautes de frappe

tu auras compris l'essentiel :)

#5 freenetstef

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 173 messages

Posté 03 juillet 2010 - 13:16

Au fait couad, je sais (enfin il me semble bien) que tu bosses sur pc toi, tu étais donc l'interlocuteur privilégié pr mon pbm

peux-tu me confirmer que sur Windows XP, il ne faut pas installer un utilitaire dédié au lissage des typos, un peu comme atm (adobe type manager) remplissait cette fonction à l'époque ?

où encore, qu'il faille activer/désactiver, cocher/décocher des paramètres spécifiques ds la configuration des paramêtres de XP ?

#6 couad

  • Members
  • PipPipPipPipPipPipPipPip
  • 1 002 messages

Posté 04 juillet 2010 - 20:35

Voir le messagenetstef, le 03 juillet 2010 - 13:16 , dit :

peux-tu me confirmer que sur Windows XP, il ne faut pas installer un utilitaire dédié au lissage des typos, un peu comme atm (adobe type manager) remplissait cette fonction à l'époque ?
où encore, qu'il faille activer/désactiver, cocher/décocher des paramètres spécifiques ds la configuration des paramêtres de XP ?
J'ai jamais installé le moindre soft qui soit dédié à du lissage de typo. Autant un gestionnaire de typo est quasi indispensable quand on a des centaines, voire des milliers de typos, mais un soft de lissage... jamais entendu parlé.

Idem pour les paramètres dont tu parles sur XP, je n'y ai jamais touché.
A l'heure actuelle, je suis sur Seven 64 bits en plus, j'ai abandonné XP au passage à la CS5.

#7 freenetstef

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 173 messages

Posté 10 juillet 2010 - 16:43

Voir le messagecouad, le 02 juillet 2010 - 20:42 , dit :

Zippes ta typo, et mets la à dispo. Je ferai un test pour te dire si ca fonctionne sur mon mac et mon PC.
Idem pour ton fichier After si tu le peux. En version allégée bien sûr. Pas besoin de tous tes médias, seule tes typos comptent.
et voilà une version super allégée du "problème" ;)

tu me diras ce que ça donne chez toi, mais j'ai bien l'impression que ça vient des typos ;)

d'ailleurs, suite à ce sujet je remarque que, lorsque je double-clic dessus depuis le bureau, mes typos apparaissent crénelées dans la fenêtre de preview, est-ce normal ?

p.s.: j'ai mis un peu de temps, je suis en vacances pr qqs jours ;)

#8 freenetstef

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 173 messages

Posté 11 juillet 2010 - 13:30

Voir le messagenetstef, le 10 juillet 2010 - 16:43 , dit :

et voilà une version super allégée du "problème" ;)

voire même un peu trop allégée ;)
allez, avé la piece jointe, c'est tjs mieux !

Fichier(s) joint(s)



#9 couad

  • Members
  • PipPipPipPipPipPipPipPip
  • 1 002 messages

Posté 14 juillet 2010 - 19:57

C'est ta typo Helvetica LT 55 Roman qui est crénelée de base.
J'ai toutes les Helvetica, et aucune n'a ce type de problème.
Ça ne pourrait pas venir de la conversion d'une typo OpenType en TrueType ce genre de problème ?

#10 freenetstef

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 173 messages

Posté 15 juillet 2010 - 00:55

Voir le messagecouad, le 14 juillet 2010 - 19:57 , dit :

C'est ta typo Helvetica LT 55 Roman qui est crénelée de base.
oui c'est ce que laissait augurer la fenetre de preview

d'ailleurs ici, les deux typos que je t'ai fait passées apparaissent crénelées ds la fenetre de preview sur le bureau

Voir le messagecouad, le 14 juillet 2010 - 19:57 , dit :

Ça ne pourrait pas venir de la conversion d'une typo OpenType en TrueType ce genre de problème ?
ce sont des typos récupérées sur le net, je n'ai fait aucune conversion

Voir le messagecouad, le 14 juillet 2010 - 19:57 , dit :

J'ai toutes les Helvetica, et aucune n'a ce type de problème.
moi, j'ai toute une typotheque sur mac, plusieurs dizaines de milliers de fontes, jamais eu ce genre de probleme, mais comme mon mac m'a planté récemment, je me suis rabattu sur mon portable asus pour gérer l'urgence, et en l'occurence un clip sur lequel je rencontre ce probleme de typo

Pourrais-je te demander de me faire passer la famille helvetica en version pc que je puisse voir si ça fonctionne chez moi ?

car l'aliasing, ça me le fait qd meme sur la majorité de mes typos ds AE, et j'en ai qd meme chargé plusieurs milliers dans le pc !

si oui, je te laisserai un mail perso :mrgreen:

#11 couad

  • Members
  • PipPipPipPipPipPipPipPip
  • 1 002 messages

Posté 15 juillet 2010 - 11:23

Le fait que tu aies des milliers de typos montre assez bien que tu télécharges tout ça sur le net à foison. Télécharger des typos sur le net c'est normal, il y a des tonnes de sites dédiés à ce type de commerce. Mais autant de typos cela prouve que tu (je te cite) "récupères" en majorité des typos qui sont loin d'être bien réalisées. Donc ca ne m'étonne pas que la majorité de tes typos soient crénelées.

Et il est évidemment hors de question que je te file la typo Helvetica et ses variantes. Une typo est, dans la plupart des cas, un produit payant. Les gens l'oublient bien vite. Et justement, si tu te rabats sur des versions non payantes, tu risques fort d'avoir des problèmes... :mrgreen:

#12 freenetstef

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 173 messages

Posté 15 juillet 2010 - 17:09

Tu aurais pu éviter toutes ces lapalissades et ce ton moralisateur, un brin sentencieux, Couad, un simple "non, cela n'est pas possible", où "ce n'est pas l'endroit" aurait été largement suffisant !

Il me semble qu'un forum est avant tout un lieu d'échange et d'entraide, où l'idée est plutôt de donner des tuyaux que de "donner des leçons".

Et je comprends bien que tu utilises les colonnes de ce forum avec comme souci premier dans respecter les règles fondamentales et aussi d'y distiller une bonne parole, en ta qualité de modérateur, mais enfin bon, point trop n'en faut tout de même.

Je ne m'étends pas sur le pourquoi du comment de mes milliers de typos, 15 ans à bosser en PAO en plus de la gratuité foisonnante du net en sont sûrement un début d'explication.

Pour rappel, mes typos "sortent" crénelées dans After Effects et ailleurs, ET le gros problème est que cela se produit AUSSI avec les polices de base du système, comme l'Arial, le Verdana, ...

Je suis un peu paumé car je viens (depuis tjs) du monde Mac et que j'ai de surcroît tjs lu, et entendu dire, que le lissage des typos n'était pas une donnée fiable sur plate-forme PC, boum, je me le prends en pleine poire, j'espèrais avoir trouvé une main secourable...

je me suis pris un désagréable rappel à l'ordre par un inopportun donneur de leçon

moi qui avait bêtement imaginé une simple entraide entre graphistes

Encore merci pour ton aide et vive le PC !

#13 couad

  • Members
  • PipPipPipPipPipPipPipPip
  • 1 002 messages

Posté 15 juillet 2010 - 18:56

J'ai beau me relire, je ne vois pas le moindre ton moralisateur ou rappel à l'ordre dans mon dernier post.
J'ai moi-même des milliers de typos téléchargées depuis des années sur le net, où que des clients m'ont fait suivre par rapport à des productions particulières.
J'évoquais juste le fait que tu étais gourmand en typo, comme tout graphiste, et qu'à force de choper toutes les typos de sites spécialisés, on a forcément dans sa librairie une majorité de typos que je qualifierais de pourries. Tu as interprété mes remarques comme une accusation de téléchargement illégal alors que je pensais à tous ces sites dédiés aux typos que tout le monde a dans ses bookmarks.
Je ne dis pas ça méchamment, mais tu te doutes que ce que font les gens de leur connexion internet c'est bien le cadet de mes soucis.

Mon étiquette de modérateur commence à me saouler profondément et ne vaut pas un rouble, je t'aurais fait les mêmes remarques en tant que membre de ce forum puisque tes fichiers et ta dernière demande m'étaient adressés.
Tu m'as demandé personnellement de te fournir une famille de typo pour t'aider, je te réponds personnellement que c'est impossible en te donnant l'explication.
Mon statut de modérateur, c'est du bénévolat pour aider les gens qui rencontrent des problèmes. Je le faisais au début sans cette mention, et je continue de le faire avec. Concernant donc mon degré d'implication dans tes problèmes et l'entraide entre graphistes, je ne m'étendrai pas sur ce sujet. Si tu veux éventuellement continuer sur ce thème, je reste à ta disposition par MP.

Si on revient à ton problème, il n'y a aucune raison pour que toutes tes typos crénèlent, même les "basiques", et dans tous les logiciels.
Ça ne le fait que quand ta typo est contrastée par rapport au fond (typo blanche sur fond noir) ou ca le fait aussi quand il y a très peu de contraste ?
Si ca le fait dans tous les logiciels et sur toutes tes machines, il ne me vient qu'une seule possibilité à vérifier mais qui me parait peu plausible : tes écrans sont peut-être beaucoup trop contrastés ce qui a tendance à afficher tes typos crènelées. Mais j'avoue ne pas trop y croire... Je pense à ça parce que j'avais à une époque un écran qui m'explosait les blancs, et qui affichait des artefacts alors qu'en réalité l'image était nickel.



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)

authorised training centre

Centre de Formation Mediabox - Adobe et Apple Authorised Training Center.

Déclaré auprès de la Direction du Travail et de la Formation Professionnelle

Mediabox : SARL au capital de 62.000€ - Numéro d'activité : 11 75 44555 75 - SIRET : 49371646800035

MEDIABOX, 23, rue de Bruxelles, 75009 PARIS

FFP