Forums Développement Multimédia

Aller au contenu

Problème sons qui se chevauchent

PAO Flash

3 réponses à ce sujet

#1 anne-laure

    Ceinture Blanche

  • Members
  • Pip
  • 2 messages

Posté 16 August 2013 - 13:07 PM

Bonjour,

Je travaille sur un animation sur Flash où lorsque j'appuie sur une touche de mon clavier différentes actions se produisent.
Sur ma scène, j'ai deux clips : l'un s'appelle "oui" et le second "non", dans ces deux clips il y a des sons différents (et contenant le même nombre d'images clé). Lorsque je clique sur l'une des touches de mon clavier la lecture se dirige vers le clip "oui" (positionné sur l'image clé 1) et la lecture se fait sans problème. En revanche, lorsque je tape sur la touche renvoyant vers mon clip "non" ((positionné sur l'image clé 2) les deux pistes audio se fondent entre elles. (Il y a aucun problème de visuels)

J'ai inséré des "stop" partout où il était possible d'en insérer en vain.
Dans les options de synchronisation, j'ai bien sélectionné dans "Démarrage" car si je me rèfére à l'aide "lorsque le son est en cours de lecture, aucune nouvelle occurrence du son n’est lue."

Je ne sais plus ce que je peux faire, je recherche donc de l'aide.
Merci d'avance.

#2 Monsieur Spi

  • Community Manager
  • PipPipPipPipPipPipPipPip
  • 7017 messages

Posté 16 August 2013 - 17:45 PM

Salut et bienvenue,

C'est le genre d'interactivité qui demande de passer par du code et de la programmation si tu veux te simplifier la vie et éviter les bugs. Renseigne toi sur la gestion du son via le code, le but est de lancer un son quand tu clique sur un des boutons, de le stopper et de lancer le second quand tu cliques sur le second bouton.

A lire :
http://help.adobe.co...edia/Sound.html
http://help.adobe.co...90204-7d21.html

A savoir, il n'est pas obligatoire de charger un MP3 externe, tu peux très bien avoir le son en bibliothèque, l'exporter pour AS et t'en servir normalement, c'est pareil que de charger du MP3 externe.

#3 anne-laure

    Ceinture Blanche

  • Members
  • Pip
  • 2 messages

Posté 16 August 2013 - 22:52 PM

Merci beaucoup pour cette aide.

J'ai eu du mal à lire et comprendre (mon niveau se limitait aux interpolations, il y a encore qqs semaines !) mais j'en suis venue à bout et cela fonctionne sans problèmes !
C'est beaucoup plus simple à mettre en plus.

#4 Monsieur Spi

  • Community Manager
  • PipPipPipPipPipPipPipPip
  • 7017 messages

Posté 16 August 2013 - 23:22 PM

Bravo, bon courage pour la suite ;-)



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)