Forums Développement Multimédia

Aller au contenu

FlashPlayer / Air bridé à 40 FPS sur une machine...

CODE Actionscript

7 réponses à ce sujet

#1 eKimiya

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 423 messages

Posté 02 July 2013 - 15:33 PM

Bonjour à tous !

Nous sommes en train de commencer à travailler sur un jeu, et du coup on testait une petite démo technique sur différentes machines.

ça fonctionne plutôt bien partout (60 FPS stable), sauf sur une machine ou le compteur s'arrête toujours à 40 FPS... Avez-vous une idée d'où cela peut venir ?

Le jeu utilise Starling/DragonBones, donc le GPU. On a regardé les pilotes de la CG, et c'est à jour... Pourtant c'est une bonne machine, qui fait tourner des jeux récent en 3D sans soucis, du coup c'est pas un soucis de performance de la machine. C'est comme si le player était bridé...

J'ai test en retirant tout, et en ne laissant que le compteur de FPS, et toujours pareil... 40 FPS :?

Avez vous déjà vu ça quelque part ??

#2 Krevare

    Ceinture Noire

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 923 messages

Posté 02 July 2013 - 15:36 PM

Hello :)

Ca ne me dis mais peut-être en connaissant l'environnement quelqu'un aura peut-être une idée ?
Genre c'est quoi l'OS, c est en AIR, flash player ? quelle version etc :)

Bonne journée,

Fred.

#3 eKimiya

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 423 messages

Posté 02 July 2013 - 15:47 PM

En effet, avec des précisions ce sera mieux :

OS : Windows Seven 64 bits
FlashPlayer : 11.7.700.225
CG : GeForce GTX 560 Ti
CPU : Intel ® Core ™ I7 CPU 940 @ 2.93 GHz

Merci !

#4 tlecoz

  • Honoris
  • PipPipPipPipPipPipPipPip
  • 3485 messages

Posté 02 July 2013 - 15:58 PM

Hello ?
C'est un PC portable ?

#5 eKimiya

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 423 messages

Posté 02 July 2013 - 19:28 PM

Non c'est une tour tlecoz ;-)

Une idée peut-être ?

#6 eKimiya

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 423 messages

Posté 04 July 2013 - 22:33 PM

Bonsoir à tous,

On vient de se rendre compte d'un truc suuuppper étrange. Lorsqu'on s'appelle sur Skype, le jeu passe à 60 FPS... Dès la conversation terminée, ça repasse à 40 FPS ! On a fait le test plusieurs fois, ça le fait tout le temps !!

C'est quoi ce truc ?! :eusa_doh:

Pour info, la case "accélération matérielle" est bien coché dans les paramètres du Flash Player.

#7 Krevare

    Ceinture Noire

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 923 messages

Posté 11 July 2013 - 16:47 PM

Bha, internet explorer accélère internet, Skype peut bien booster flash !

Non blague à part, aucune et idée Oo

Fred.

#8 eKimiya

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 423 messages

Posté 11 July 2013 - 17:04 PM

Ahah ! :D

En fait, le soucis semble être posé par le "plugin-container" de Firefox... Du coup ça fonctionne bien lorsque Firefox est fermé !
ça reste très étrange et on comprend pas bien ce qui ce passe, mais au moins on peut tester correctement :roll:



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)

authorised training centre

Centre de Formation Mediabox - Adobe et Apple Authorised Training Center.

Déclaré auprès de la Direction du Travail et de la Formation Professionnelle

Mediabox : SARL au capital de 62.000€ - Numéro d'activité : 11 75 44555 75 - SIRET : 49371646800035

MEDIABOX, 23, rue de Bruxelles, 75009 PARIS

FFP