Forums Développement Multimédia

Aller au contenu

Problème de positionnement dans Safari mobile

CODE HTML CSS

7 réponses à ce sujet

#1 Gilles_73

    Ceinture Jaune

  • Members
  • PipPip
  • 22 messages

Posté 09 February 2013 - 12:25 PM

Bonjour,
Je viens solliciter votre aide vous car j’ai un petit souci sur une page web que je viens de créer et je n'arrive pas à résoudre le problème


L'adresse de la page :

www.nolorguesmetaux.com/test/index.html

En fait tout fonctionne bien dans les principaux navigateurs mac et pc sauf dans la version mobile de Safari où la partie centrale ainsi que mon footer sont alignés sur la gauche alors que l'ensemble devrait être centré.

J'ai fait une capture sur mon iphone.

Image attachée: photo.jpg

Une idée ?

Merci d'avance,

Gilles

#2 Gilles_73

    Ceinture Jaune

  • Members
  • PipPip
  • 22 messages

Posté 10 February 2013 - 10:19 AM

Je viens d'essayer pas mal de choses pour résoudre mon problème mais rien y fait....Peut être ma page est finalement mal construite ?

#3 dcz.switcher

  • Community Manager
  • PipPipPipPipPipPipPipPip
  • 2532 messages

Posté 10 February 2013 - 16:59 PM

Salut,

J'ai jeté un oeil vite fait, tu as testé en mettant la div class='body' en width 100% ?
"Ce que l'on conçoit bien s'énonce clairement et les mots pour le dire arrivent aisément"

embryon de site

#4 Gilles_73

    Ceinture Jaune

  • Members
  • PipPip
  • 22 messages

Posté 10 February 2013 - 17:49 PM

Merci pour ta réponse.
Je viens d'essayer et toujours le même problème...

#5 dcz.switcher

  • Community Manager
  • PipPipPipPipPipPipPipPip
  • 2532 messages

Posté 10 February 2013 - 20:46 PM

Est-ce que tu as essayé avec une version light sans contenu de la page, ni CSS superflu, juste pour pouvoir manipuler les blocs et reproduire le soucis ?

L'avantage c'est qu'on pourrait partager ce code et tester.
"Ce que l'on conçoit bien s'énonce clairement et les mots pour le dire arrivent aisément"

embryon de site

#6 Gilles_73

    Ceinture Jaune

  • Members
  • PipPip
  • 22 messages

Posté 10 February 2013 - 23:24 PM

Merci de ton aide.........alors j'ai fait donc deux versions et j'ai trouvé la balise qui fait planter : "conteneur_texte_visuel_main"

versiuon initiale :

http://www.nolorgues...test/index.html

version light sans la div "conteneur_texte_visuel_main" dans le code source :

http://www.nolorgues...ight/index.html

J'ai du forcément mal m'y prendre dans l'emboîtement des div !

#7 Gilles_73

    Ceinture Jaune

  • Members
  • PipPip
  • 22 messages

Posté 12 February 2013 - 19:27 PM

Salut,
Toujours un peu de mal à solutionner mon problème.......une idée ?

#8 pol2095

  • Members
  • PipPipPipPipPipPipPipPip
  • 1799 messages

Posté 13 February 2013 - 11:06 AM

il y a des balises CSS qui sont mal interprétées sur les navigateurs mobile, par exemple je me suis aperçu que "fixed" pose problème.



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)