Forums Développement Multimédia

Aller au contenu

A propos de Starling

CODE Actionscript

1 réponse à ce sujet

#1 William27wp

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 168 messages

Posté 21 November 2012 - 12:14 PM

Bonjour à tous,

je découvre Starling et fait quelques tutoriaux mais je rencontre un problème inédit que je ne parviens pas à résoudre.
Il me semble que Chrome ou IE refusent d'afficher les swf lorsque Starling est impliqué dans ces derniers.
J'ai créé d'autres applications en 11.2 dont une avec Papervision3D et elle se lance sans souci que ce soit sous Chrome ou IE.

Quelques posts dans des forums m'ont expliqué de ne pas cibler directement 11.5 dans le swf, c'est la raison de mon choix en 11.2.
J'ai bien vérifié que le wmode soit direct dans le swf embarqué dans la page web mais rien n'y fait.
Chrome me demande systématiquement d'installer la dernière version de 11.5 (comportement étrange puisqu'elle est déjà construite dans Chrome) ; Quant à IE, il n'affiche que rien (si je recharge la page, il apparaît brièvement un rectange gris mais aucun message ne l'accompagne).

Mes différents tests m'ont donc presque convaincu que le problème vient de l'intégration de Starling dans le swf d'où ma question.

Merci de partager vos éventuels expériences.

#2 William27wp

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 168 messages

Posté 21 November 2012 - 19:03 PM

Bon, j'ai trouvé une solution


<param name="wmode" value="direct">
<param name="swfversion" value="6.0.65.0">

swf en 6.0.65.0 et non pas en 15.0.0.0 lance le snippet que ce soit sous Chrome ou IE.

Nom : Shockwave Flash

Description : Shockwave Flash 11.4 r402

Version : 11,4,402,287


J'ai bien le plug-in Flash sous Chrome (j'ai désactivé la mouture intégrée).
Bon.. Là ça me dépasse.

Si quelqu'un pouvait me mettre sur la piste de quelques informations pas trop technique..



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)