Forums Développement Multimédia

Aller au contenu

Gros bug IETester et requête SQL

SQL IETester Internet Explorer Images bug CODE Actionscript

8 réponses à ce sujet

#1 XueFang

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 77 messages

Posté 21 September 2012 - 11:54 AM

B) Salut à tous,
Aujourd'hui je ne passe pas demander de l'aide mais rapporter un bug qui m'est arrivé il y à quelques jours et qui peut arriver à d'autres.

Si comme moi vous voulez créer vos sites web de manière consciencieuse pour qu'ils fonctionnent sur tous les navigateurs :roll: J'ai bien dis tous... Sans aucun commentaire pour un certain navigateur qui n'est jamais d'accord avec les autres.
Vous allez donc avoir recourt à des outils, des widgets, des extensions, appelez ça comme vous voulez. Qui vous serviront à débugger vos sites web pour le plus grand bonheur de vos visiteurs.

Eh bien voilà je suis comme vous ai j'utilisai donc le software "IETester" qui permet de vérifier la compatibilité sur les anciens moteurs d'internet explorer ( :ph34r: oops je viens de dire le nom ). Je sais bien qu'IE9 intègre déjà cette fonctionnalité... mais qui n'est pas 100% fiable, alors je complétais avec ce software.
Le problème il est que j'ai eu la mauvaise surprise après des semaines de travail sur un site, de vouloir observer sa compatibilité sur tous les navigateurs après l'avoir terminé... Chrome OK, Firefox OK, IE...OK pour IE9... pas pour IE8 et IE7. Du coup mon site étant en Flash, j'ai juste modifié la manière d'intégrer mon .swf à l'aide de swfobject. Et là le site s'est affiché sous IE7 et IE8 et tous les autres navigateurs sans aucun probl... :blink: UNH?! Pourquoi je n'ai plus d'images dans mon site? Et sur aucun autre navigateur?
Eh bien oui! Après un long moment de recherche et de revérification de mon code, j'ai finis par comprendre que le software qui était censé m'aider à débugger mon site, avait parasité tous les navigateurs. La requête SQL se faisait bel et bien car les textes récupéré depuis la base SQL s'affichaient mais les images étaient inexistante.
Du coup le temps que je comprenne ce qui m'étais arrivé ma réaction ressemblait à ça :angry: :twisted: :evil: :mad: :eusa_doh: :sad: :shock: :o <_< :wacko: :blink: :unsure:

Enfin pour palier à se problème il suffit tout simplement de désinstaller proprement IETester.
Voilà j'espère que sa servira un jour à quelqu'un :)

#2 Krevare

    Ceinture Noire

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 923 messages

Posté 21 September 2012 - 12:17 PM

Merci, c'est toujours bon de lire ce genre d'info, ça reste stocké quelque part au fond de nos têtes !

Fred.

#3 alama.be

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 224 messages

Posté 21 September 2012 - 13:40 PM

Merci ;)
Ne baisse jamais les bras, car c'est à ce moment là que le miracle risque de se produire..

Site web: http://www.pureas3.org
Twitter: https://twitter.com/PureAS3

Enjoy with Flash Player :-)

#4 jfr

    Ceinture Blanche

  • Members
  • Pip
  • 1 messages

Posté 21 September 2012 - 21:18 PM

Bonjour,

Est-ce que vous pourriez expliquer le probleme que vous avez eu avec IETester ? Je ne comprends pas comment IETester peut generer des problemes au niveau sql (qui est niveau serveur) ou interferer avec d'autres browsers, chrome, firefox, etc.

Est-ce qu'il est possible de reproduire ce probleme ? Si oui comment ?

Si c'est vraiment un bug sous IETester, j'aimerai le corriger dans une prochaine version.

Merci.

----
Fabrice
http://www.debugbar.com

#5 Nataly

    Community Jane

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 5783 messages

Posté 22 September 2012 - 10:09 AM

Merci, c'est vraiment sympa de prendre le temps de transmettre l'expérience (en plus c'est rigolotement raconté ;))
Le savoir est le seul bien qui s'accroit quand on le partage
une tartine de tutos

#6 hu9o

  • Members
  • PipPipPipPipPipPipPipPip
  • 653 messages

Posté 07 October 2012 - 19:14 PM

Merci pour le rapport informatif et informel :smile:

...mais IE8 et IE7 ? Faut-il vraiment s'en soucier (la 10 sort bientôt) ?

(perso quand j'ai un site qui s'affiche bien dans IE9 je suis content :mrgreen: )

#7 XueFang

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 77 messages

Posté 07 October 2012 - 22:45 PM

:D Si ça ne tenait qu'à moi j'exterminerai de ma liste ce navigateur... mais bon tout le monde n'est pas fana des updates de leur PC

#8 hu9o

  • Members
  • PipPipPipPipPipPipPipPip
  • 653 messages

Posté 08 October 2012 - 09:26 AM

Ouais c'est naze IE...

Je préfère mon bon vieux Netscape 3 :mrgreen:

#9 XueFang

    Ceinture Bleue

  • Members
  • PipPipPipPipPip
  • 77 messages

Posté 08 October 2012 - 11:26 AM

:blink:

Citation

Je préfère mon bon vieux Netscape 3 :mrgreen:




1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)

authorised training centre

Centre de Formation Mediabox - Adobe et Apple Authorised Training Center.

Déclaré auprès de la Direction du Travail et de la Formation Professionnelle

Mediabox : SARL au capital de 62.000€ - Numéro d'activité : 11 75 44555 75 - SIRET : 49371646800035

MEDIABOX, 23, rue de Bruxelles, 75009 PARIS

FFP