Forums Développement Multimédia

Aller au contenu

précharger des vidéos sur un .swf

PAO Flash

2 réponses à ce sujet

#1 Xari

    Ceinture Blanche

  • Members
  • Pip
  • 14 messages

Posté 01 August 2012 - 10:47 AM

Bonjour à tous !

J'ai quelques problèmes avec mon animation flash, je travaille sur un petit projet pour un guide de jeu, l'idée est simple, j'ai représenté la carte du jeu en petit, et en cliquant sur des boutons je fais apparatire en vidéo le personnage se mouvant en jeu.

Chaque bouton est donc associé à une vidéo en .mp4 pesant jusqu'à 800ko.
En local, tout fonctionne très bien, par contre dès que j'exporte mon animation flash, et que j'héberge mes vidéos sur mon serveur ftp, lors du lancement de la vidéo, celle-ci se "charge" et provoque donc un effet très saccadé.

J'aimerais savoir comment remédier à cela... Y-a-t-il un moyen de charger toutes mes vidéos avant le début de l'animation en laissant un petit loader qui s'enlève une fois que l'animation est "prête" ?
Ou peut être une meilleure solution ?

Merci d'avance :).

#2 Krevare

    Ceinture Noire

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 923 messages

Posté 01 August 2012 - 11:21 AM

Hello :)

Tu trouveras la solution dans ce post :
http://www.actionscr...d.php3?t=222390

Je ne l'ai pas testée mais le type dit que ça marche.

L'idée est la suivante : Tu écoute ou en est le buffering de la vidéo et lorsqu il est terminé, ca veux dire que tout est loadé, la tu lance la vidéo.

Voilou, pour faire patienter les utilisateurs tu peux faire une petite anim genre un sablier ou que sais-je, et de la même manière tu retire l'anim lorsque le buffer est full :)

Amuse toi bien,

Fred.

#3 Xari

    Ceinture Blanche

  • Members
  • Pip
  • 14 messages

Posté 01 August 2012 - 11:40 AM

Re !
Je vois le genre, mais le problème c'est que j'aimerais tout charger avant le début de l'animation en fait. Car faire attendre l'utilisateur à chaque vidéo n'est vraiment pas souhaitable :(. Je préfère qu'il attende plus longtemps mais une seule fois ^^.



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)