Forums Développement Multimédia

Aller au contenu

Silex version 1.7.0RC1- Bugs

bugs CMS Silex

6 réponses à ce sujet

#1 Diguet Mélissa

    Ceinture Blanche

  • Members
  • Pip
  • 4 messages

Posté 12 June 2012 - 15:52 PM

Bug de fonctionnement:

-hyperliens ne fonctionnent plus
-téléchargement de pdf ne fonctionne plus
-tout fonctionne si on le met sur la page start (mais pas sur les autres pages)
-les simple gallery ne fonctionnent qu'en mode automatique (en mode manuel ça affiche seulement la première image)
-problème de frame (plugin googlemap) : s'affiche hors cadre dans firefox pc version 13.0 (testé sur 2 pc, sur l'un fonctionne normalement firefox 12.0, sur l'autre ne fonctionne pas firefox 13.0)

Merci d'avance

#2 Diguet Mélissa

    Ceinture Blanche

  • Members
  • Pip
  • 4 messages

Posté 12 June 2012 - 16:35 PM

Pour être plus précis:

-Les hyperliens du type : [[http://www.blabla.com|Blabla]] sur du texte ne fonctionnent pas

-Le téléchargement de données via l'action du type : onRelease download:media/mobilhome/pdf_contrat/tableau_tarifs_2012.png ne fonctionne pas (aucun fichier ne se télécharge)

-Appliquées à la page souhaitée, ces actions ne fonctionnent pas, sauf si on les met en page start (là, elles fonctionnent)

-La simple gallery ne fonctionne que lorsque le mode "défilement automatique" est activé. Si il ne l'est pas, la première image s'affiche tout de même, mais il est impossible de faire défiler les autres manuellement.

-La frame (plugin google map) s'affiche hors cadre sur un pc utilisant le navigateur firefox version 13.0, alors qu'elle s'affiche normalement sur un autre pc utilisant le navigateur firrefox version 12.0


Merci d'avance

#3 pol-silex

    Ceinture Blanche

  • Members
  • Pip
  • 3 messages

Posté 12 June 2012 - 16:42 PM

Bonjour,

1. assurez vous de disposer de la dernière version de Silex
téléchargez la :
http://projects.silexlabs.org/?/silex#/flash.cms/download

2. Avant de supposer que tu parles bien de bugs, assure toi de faire les trucs dans l'ordre. Car les bugs sont signalés dans la bug list et non le forum.

3. Pour nous permettre de t'aider tu dois être plus explicite que (par exemple) : hyperliens ne fonctionnent plus
dans l'état je ne vois ce que tu veux dire ni quel truc tu as tenté de faire (une action ? sur quoi ? etc...).

idem pour le "téléchargement de pdf ne fonctionne plus"

4. tout fonctionne si on le met sur la page start (mais pas sur les autres pages)
de quoi parles tu ? des liens, du download...?

5. -les simple gallery ne fonctionnent qu'en mode automatique (en mode manuel ça affiche seulement la première image)
c'est le propos même de la simple gallery. En mode manuel on suppose que l'utilisateur (visiteur) va cliquer sur les boutons suivants - précédents pour "naviguer" dans les images - autrement en effet, rien ne se passe (ce qui distingue ce mode du mode automatique).

6. -problème de frame (plugin googlemap) : s'affiche hors cadre dans firefox pc version 13.0 (testé sur 2 pc, sur l'un fonctionne normalement firefox 12.0, sur l'autre ne fonctionne pas firefox 13.0)
je te confirme que les frames sont capricieuses. En fait pour visualiser le résultat de ton placement tu dois passer en mode navigation voir même rafraichir ta page.

Bon courage.
Pol

#4 pol-silex

    Ceinture Blanche

  • Members
  • Pip
  • 3 messages

Posté 12 June 2012 - 17:01 PM

  • -Les hyperliens du type : [[http://www.blabla.com|Blabla]] sur du texte ne fonctionnent pas

    [[http://www.google.fr|google]]

    Fonctionne correctement chez nous sur start et tous les autres calques.
  • L'action (par exemple) utiliser dans le thème par défaut de la dernière release

    onRelease download:media/silex-business-card/silex_silexlabs_usefull-links.pdf

    Fonctionne correctement chez nous sur start et tous les autres calques.
  • la simple gallery : assure toi d'avoir coché le paramètre affichant les flèches qui permettent de passer d'une image à l'autre.
    si ce problème persite, reporte toi sur le doc
    http://www.silexlabs...simple-gallery/
  • Les frames ont en effet un comportement erratique
    quand tu parles de différence d'affichage - est ce que l'un des postes est en mode "edit" Silex ou pas ?
    le fait est que lorsque l'on maquette un site contenant des frames, le fait (par exemple) que la barre d'outils soit affichée en bas de page peut "contrarier" l'affichage normal.
Bon courage.
Pol

#5 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 12 June 2012 - 17:12 PM

Bonjour Mélissa !
Bienvenue parmi nous...

Juste un conseil par rapport aux questions comme les tiennes : le mieux est d'ouvrir un sujet par question
On a souvent des nouveaux venus qui attendent d'avoir 25 questions pour les poser dans le forum, mais la meilleure technique est de le faire au fur et à mesure...

N'oublie pas de préciser ta version de silex. Et le mieux est de nous montrer un exemple en ligne...

Quant à tes questions, j'ai dirais pareil que pol... Ca me semble marcher. J'ai testé les liens texte sur http://www.softaculous.com/demos/Silex et ca fonctionne.

#6 Roi valeureux

    Ceinture Blanche

  • Members
  • Pip
  • 6 messages

Posté 14 June 2012 - 11:43 AM

C'est vrai on pense toujours aux bugs quand ça ne fonctionne plus, alors qu'il s'agit souvent d'une mauvaise manip. de l'utilisateur.

Et pour répondre à Mélissa, concernant les problèmes que tu décris (liens/texte non cliquables, galeries non cliquables),
vérifie s'il n'y a pas un élément (invisible) au dessus de tes liens/texte et galeries qui empêche qu'ils soient cliquables.

Surtout si tu utilises des gabarits de page de type "minimal_plus" (car toutes les pages créées à partir de celle-ci se retrouveront "prises en sandwich" entre le calque over et le calque under de la page)

Ce qui me met la puce à l'oreille, c'est que ça fonctionne quand tu poses ces éléments sur la page start (calque Over) de ta publication.

En te souhaitant de résoudre ces problèmes.

#7 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 14 June 2012 - 12:19 PM

Bien vu RV... :roi:



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)

authorised training centre

Centre de Formation Mediabox - Adobe et Apple Authorised Training Center.

Déclaré auprès de la Direction du Travail et de la Formation Professionnelle

Mediabox : SARL au capital de 62.000€ - Numéro d'activité : 11 75 44555 75 - SIRET : 49371646800035

MEDIABOX, 23, rue de Bruxelles, 75009 PARIS

FFP