Forums Développement Multimédia

Aller au contenu

le format vidéo ou le type MIME n'est pas géré

gallery galerie CMS Silex

4 réponses à ce sujet

#1 bountyty

    Ceinture Blanche

  • Members
  • Pip
  • 4 messages

Posté 11 April 2012 - 09:57 AM

bonjour,
J'ai un gros problème pour voir les images présente dans "simple gallery" ou même j'en ai créer une en utilisant "oof component" mais non ça ne s'affiche pas.!
Même quand j'utilise un "tuto.gallery" déjà tout prêt je ne vois pas les images qui appartiennent à la galerie.
Pourtant quand j'ajoute simplement un composant "image" jpg ou gif ça marche !Je le vois en local et en html
les vidéos mp4 je les vois quand j'utilise des thèmes tout fait comme "video.blog" mais pas quand j'utilise
un calque dans un thème que j'ai personnalisé pour voir.
http://www.maisonesq...mepage%20button
L'erreur pour le mp4 dans FIREFOX c'est le format vidéo ou le type MIME n'est pas géré ...sur Internet explorer j'ai juste une croix et rien d'autre.
pour thème gallery.tuto même quand je le charge directement je ne vois pas les images en html seulement en local!
Quand je veux ajouter un mp4 qui fonctionne dans un thème "tout fait" quand je le charge à partir du manager TOUT FONCTIONNE ...en local comme en html
C'est pourquoi je m'adresse à vous parce que je pense que ça doit venir du manque d'un fichier ou autre ...? certainement du fait que je ne maîtrise pas encore bien l'utilisation de SILEX SERVER.
J'espère vraiment que vous m'aiderez à trouver une solution car j'aimerais vraiment comprendre SILEX SERVER.
j'ai une adresse windows live "marieline061@hotmail.fr" pour pouvoir "discuter" en ligne.
Merci d'avance pour votre aide.

#2 koala_silex

    Ceinture Orange

  • Silex Lab
  • PipPipPip
  • 35 messages

Posté 11 April 2012 - 12:32 PM

Bonjour bountyty,

Alors, pour répondre à tes questions :

- format vidéo mp4 : si tu utilises la version V1.6 de silex, il est "normal" que le format mp4 ne marche pas ; il s'agit en fait d'u bug sur cette version et seul le flv est reconnu. Par contre, avec la version actuelle du silex server (v1.7.0) le mp4 fonctionne

- gallery d'images : il faut savoir que les composants oof ne sont pas reconnus à ce jour en version html5 - donc une galerie d'images avec oof ne sera pas visible en html5
Le problème est le même avec la "simple gallery" - elle n'est à ce jour pas reconnue par le html5

Seuls les jpg et les png (pour les images) sont pris en compte par le html5, c'est pour cela que, insérés en dehors d'une galerie ils sont visibles.

En espérant que cela puisse t'aider...

N'hésite pas en tout cas à reposer d'autres questions.

Bien à toi,

le koala

#3 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 11 April 2012 - 19:32 PM

Perso je n'ai pas tout compris (1 problème a la fois serait peut etre plus simple)


Pour la video, il semble que le mp4 ne soit pas lu par firefox, pour des raisons de brevet etc
cf http://en.wikipedia....iki/HTML5_video

Donc peut etre que tu devrais embeder la dans le player vimeo qui gère ça je crois

#4 bountyty

    Ceinture Blanche

  • Members
  • Pip
  • 4 messages

Posté 12 April 2012 - 08:46 AM

tout d'abord je tiens à vous remercier pour vos réponses.
Ensuite pour répondre à koala_silex j'utilise le dernier silex_server en ligne 1.7 RC1 mais c'est vrai que je l'avais pas précisé...
Je pense que _lex n'est pas loin de de trouver la solution au problème en tous cas ça me donne une piste pour chercher.
Ce que je tiens à souligner c'est que je peux voir la vidéo qui est incluse dans par exemple le thème blog_vidéo par contre quand j'ajoute un composant vidéo mp4 (la même vidéo) dans un thème comme business_visicard auquel j'ajoute un calque sur lequel j'ajoute ensuite le composant vidéo mp4 et bien là j'ai l’erreur le format vidéo ou le type MIME n'est pas géré.J'utilise aussi bien internet explorer que Firefox pour les tests. dans internet explorer j'ai une croix à la place de la vidéo.
je vais essayer de tester avec le player vidéo pour voir ce que ça donne.
Encore merci à tous les deux et à tous les développeurs à qui on doit ce super Silex_server.

#5 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 12 April 2012 - 09:43 AM

bountyty, je vois que le thème blog_vidéo est en version Flash, pas de html... Donc c'est normal?



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)

authorised training centre

Centre de Formation Mediabox - Adobe et Apple Authorised Training Center.

Déclaré auprès de la Direction du Travail et de la Formation Professionnelle

Mediabox : SARL au capital de 62.000€ - Numéro d'activité : 11 75 44555 75 - SIRET : 49371646800035

MEDIABOX, 23, rue de Bruxelles, 75009 PARIS

FFP