Forums Développement Multimédia

Aller au contenu

hierarchisation calques + swf

CMS Silex

4 réponses à ce sujet

#1 ben451362

    Ceinture Jaune

  • Members
  • PipPip
  • 23 messages

Posté 11 April 2011 - 12:04 PM

Bonjour tout le monde,

J'ai un souci concernant la hiérarchisation de mes calques. Je m'explique : sur ma page d'accueil (calque <start>), j'ai intégré une animation SWF. Lorsque que clique sur mon menu, ce dernier créé des calques enfants(jusque là, tout va bien). Sur ce calques, j'aimerai intégrer des images de fond (pour une page de contact par exemple) qui, du coup, sois au-dessus de mon animation. Sauf que j'ai constaté que l'animation est au-dessus de mon fond...

Pensant que ça venait de mon calque <start> (parent de tout les calques donc dominant), j'ai enlevé cette animation, et l'ai injectée sur tous les calques enfants. Puis, sur ces derniers, j'y ai injecté mon fond (soyons fou, toujours cette page contact).

Je tiens à préciser que je créer les calques enfant sur le modèle "minimal_plus" en pensant que je pourrai jouer sur les calques "over" et "under"

Et là, c'est le drame, toujours le même problème, l'animation se retrouve au-dessus de mon fond (pourtant, j'ai fait attention de mettre l'animation sur le calque "under" et le fond sur "over").

Si quelqu'un à déjà eut ce souci et qu'il l'a réglé, pourrait-il me renseigner sur la démarche à suivre???

En vous remerciant par avance.

#2 POL 2008

  • Guests

Posté 11 April 2011 - 12:41 PM

Salut Ben,

il faut que tu fasses quelques tests d'ouverture de page enfant avec des layout différents.
Tu constateras qu'à la création de calque, t'es proposé plusieurs layouts.

Certains de ces layouts ouvrent les pages enfants au dessus, certains layouts ouvrent les pages enfants en dessous.

A priori en grattant 10 minutes tu devrais trouver une solution à ton problème.

Tiens nous au courant.

Pol

ps : si tu publies ton site, n'hésite pas à nous faire parvenir l'adresse et les login/pass (par message privé) pour que nous puissions jeter un oeil.

#3 ben451362

    Ceinture Jaune

  • Members
  • PipPip
  • 23 messages

Posté 11 April 2011 - 13:28 PM

Merci POL, je vais continuer mes tests en ce sens.

J'ai aussi vu sur la doc de silex : http://community.sil...de/?page_id=878
que l'on pouvait directement modifier les gabarit, les personnaliser. Mais bon, je vais essayer avec tes conseils. Si ça ne fonctionne pas, je vais tester les modifs dans les fichier .fla.

Merci pour tes conseils en tout cas.

#4 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 11 April 2011 - 14:29 PM

Tu peux aussi changer le gabarit du 1er calque (start). Pour cela, manager > gérer > ta publication > gabarits

#5 ben451362

    Ceinture Jaune

  • Members
  • PipPip
  • 23 messages

Posté 11 April 2011 - 14:37 PM

J'ai trouvé une solution, je ne sais pas si c'est très "propre", mais grosso modo, j'ai intégré mon fond dans un "Objet Encapsulé", ça apparaît bien devant mon animation incluse dans mon calque <start>. De plus, la calque dans lequel j'appel mon fond est dans un gabarit "minimal_best", je ne pense pas que ça vienne de cela, mais sait-on jamais.

Mais je ne savais pas que l'on pouvait modifier le gabarit du calque <start>, je vais tester ça de suite :).

Merci de votre aide.



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)