Forums Développement Multimédia

Aller au contenu

PB utilisation wordpress.com en back Office

CMS Wordpress

22 réponses à ce sujet

#1

  • Guests

Posté 09 September 2009 - 00:19 AM

Bonjour,

J'ai créé un site sur wordpress.com et j'espérais pouvoir en utiliser le feed RSS pour alimenter mon site silex en cours de création... et ce, en suivant à la lettre, le PDF dispo dans le forum pour ce type de paramétrage (objet OOF).
URL du feed que je souhaite utiliser : htt://xxxxxx.wordpress.com/feed

Mais, je n'arrive pas à obtenir la page workpage évoquée dans la page 36 du PDF et donc à insérer un objet texte pour la restitution des articles du "feed" via les accesseurs évoqués dans la suite des étapes du PDF.

Merci mille fois pour ce merveilleux outil et votre réactivité sur le forum.

#2

  • Guests

Posté 09 September 2009 - 00:41 AM

Petit complément, j'ai bien défini mon selector dans l'onglet "nav" en icone et en lui donnant le nom de "workpage"

Une idée, une piste ??

#3 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 09 September 2009 - 11:50 AM

il me vient une idée : remplis le paramètre "deeplink format" dans le 1er onglet des propriétés. mets un truc genre "test" puis si ca ouvre la page tu pourras remplacer par quelque chose genre <<title>>
si ca n'est pas ca alors :
  • puis je le voir en ligne stp?
  • ta liste est bien remplie n est ce pas?
  • verifie le nom de la liste (respecter la casse et pas de points dans les noms)
  • mets cette action sur le selecteur :
    Code: Tout sélectionner
    onRelease alert:click selector

    ca devrait afficher "click selector" quand tu click dans la liste


#4

  • Guests

Posté 11 September 2009 - 00:09 AM

Pas mieux avec tes manips...

Par contre, le contenu de ton message me fait tiquer...
ta liste est bien remplie n est ce pas?

=> qu'entends tu par là ? Je ne vois absolument rien apparaître sur le site silex (même après un rechargement de la page), mais mon feed contient bien 2 articles...

Malheureusement, je n'arrive pas à mettre mon site sur Chez...problème avec Log.php
je suis en local sur Wamp.
Ce que j'ai fait, étape par étape
1-J'ai posé mes objets OOF sur la page par défaut (RSSconnector/RichTextList/ListUI/DataSelector)
2-j'ai suivi les consignes du pdf, en utilisant les mêmes noms exactement (même casse,...). D'ailleurs question : est-ce normal de nommer les 2 composants RichTextList/ListUI avec le même nom "list"
3-impossible de cliquer sur "workpage"

:idea: :idea: :?: :geek:

#5 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 12 September 2009 - 17:36 PM

ok, c est dur si je ne peux pas voir...
j'ai besoin de la liste des proprietes que tu as mis pour chaque element...
et donc ta liste reste vide?
tu peux ziper le repertoire de ton site dans silex_server/content/ et me l envoyer
lex [at] silex-ria [.] org

#6 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 25 September 2009 - 12:08 PM

Bon, j'ai vu ton site Cédric...
En effet la liste n'a aucun element. mais le RSS est bien chargé (je l ai vu en utilisant firebug)

RssConnector.cmp.swf -
nom : connector
url base : <<silex.rootUrl>>cgi/scripts/proxy.php?url=

DataSelector.cmp.swf
nom: selector
connector name : connector
source : http%3A%2F%2Fgfyparis.wordpress.com%2Ffeed


et qu'as tu mis dans "format de cellule" de ton selector?

#7

  • Guests

Posté 27 September 2009 - 22:23 PM

Je n'ai rien changé dans les autres paramètres

Dans le selector :
Cell content : ((<<title>>))
where clause : 1
selected fields : *

Dans ton mail, tu me disais ne pas avoir trouvé l'adresse de mon site... :?: :?:
Est-ce dans ce paramètre que je devrais avoir l'URL de mon site ? <<silex.rootUrl>> e-il un paramètre système o faut-il le remplacer par l'URL du site Silex ?
nom : connector
url base : <<silex.rootUrl>>cgi/scripts/proxy.php?url=

Merci encore pour on aide,
Cédric

#8

  • Guests

Posté 02 October 2009 - 01:00 AM

Bahh, je suis toujours coincé... pas d'idée ??

#9 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 02 October 2009 - 19:01 PM

Dans ton mail, tu me disais ne pas avoir trouvé l'adresse de mon site...

je l'ai trouvé dans ton 2e mail je crois
Est-ce dans ce paramètre que je devrais avoir l'URL de mon site ? <<silex.rootUrl>> e-il un paramètre système o faut-il le remplacer par l'URL du site Silex ?

c'est un accesseur silex qui est remplacé automatiquement par l adresse du site

#10 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 02 October 2009 - 19:03 PM

OK J AI TROUVE :

dans ton selecteur, dans "list name" tu avais mis "list"
sur la scene tu as 1 liste qui s'appelle "List" (majuscule)
et une list ui (scroll bar) qui s'appelle "list"

donc j ai mis "List" dans le selecteur et ca marche 8-)

#11

  • Guests

Posté 06 October 2009 - 00:20 AM

Effectivement, CA MARCHE.... :roll: :D :D
Mille mercis.

Bon, par contre sans vouloir faire le désagréable dans le doc PDF de tuto (T_WORDPRESS_SILEX_fr.pdf, page 35/Paramétrez les composants RSS), la distinction n'est pas faite... d'où l'erreur ! :mrgreen:

Encore, merci... Y a plus qu'à peaufiner maintenant...
CéD

#12 contact.sharof

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 199 messages

Posté 06 October 2009 - 11:44 AM

ok, merci je note

#13

  • Guests

Posté 07 October 2009 - 01:19 AM

Une petite question supplémentaire... :roll: :roll:

Est-il possible de ne pas passer par un selector pour afficher le contenu d'un flux, dans le cas où je n'aurais qu'un "article" wordpress source (et donc, n'ayant pas besoin de faire le choix dans le selector sur le Title, comme dans l'exemple) ?

Merci d'avance,
CéD

#14 contact.sharof

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 199 messages

Posté 07 October 2009 - 14:34 PM

yes, dans ce cas tu poses l'action suivante sur ton selector

Code: Tout sélectionner
onResult selectedIndex=0


#15

  • Guests

Posté 08 October 2009 - 23:36 PM

Salut,

Toujours sur le thème : le triplet Connector/Selector/RichTextList sont mes amis... :lol: :mrgreen:

Je cherche à faire une zone de ma page, où j'aurais 2 images cliquables me permettant de choisir entre 2 flux RSS à afficher, et j'aimerais que le contenu de ma liste change sur le clic... j'envisageais de faire ça en associant au clic, l'action de changer le paramètre source du Selector, genre :
onRelease Selector_RSS.set: _source,URL encodée

Possible ? Syntaxiquement incorrect ? :idea:
CéD

PS : au fait, l'action précédente fonctionne très bien, merci

#16

  • Guests

Posté 08 October 2009 - 23:43 PM

Autres questions,

Comment puis-je faire en sorte que les éléments de ma liste soit directement des liens ramenant vers un site externe...? A l'image d'un lecteur RSS, je souhaite afficher que les titres des news et sur le clic ouvrir une fenêtre pointant vers le lien ramenant sur le site externe et le détail de la news.

Questions subsidiaires :
- comment modifier la restitution des éléments de la RichTextList, pour changer les couleurs, mettre en gras, ... ?
- mes accents de mes titres de news sont transformés en caractères asiatiques, est-il possible de forcer l'enodage :idea:

Merci pour vos réponses,
CéD

#17 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 09 October 2009 - 00:38 AM

CéD a écrit:onRelease Selector_RSS.set: _source,URL encodée
Possible ? Syntaxiquement incorrect ?

en fait en regardant la doc de l'api oof je pense que ca n'est pas source mais formName qu il faut utiliser
Code: Tout sélectionner
onRelease Selector_RSS.set:formName,URL encodée

ou encore
Code: Tout sélectionner
onRelease Selector_RSS.formName=URL encodée

et apres il faudra sans doute raffraichir les données en faisant
Code: Tout sélectionner
onRelease Selector_RSS.formName=URL encodée
onRelease Selector_RSS.getRecords


#18

  • Guests

Posté 14 October 2009 - 00:21 AM

Bonsoir,

Un petit UP pour mes 2 questions ci-dessus restées sans réponse :
- comment modifier la restitution des éléments de la RichTextList, pour changer les couleurs, mettre en gras, ... ?
- mes accents de mes titres de news sont transformés en caractères asiatiques ou carrés, est-il possible de forcer l'encodage ?
- comment faire un lien sur un élément d'une liste liée à un connector/selector ?


Merci pour le lien vers la doc des copmposants OOF, je suis pas trop manchot en programmation, mais là j'avoue que la doc me laisse perplexe... Difficile de s'y retrouver et de relier à ce que l'on manipule dans l'interface Silex :| :|

Heureusement que le forum est là pour aiguiller judicieusement, les petits amateurs :? :roll:

Ciao !

#19 contact.sharof

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 199 messages

Posté 14 October 2009 - 13:12 PM

- comment modifier la restitution des éléments de la RichTextList, pour changer les couleurs, mettre en gras, ... ?

que tu utilises "labels" de la RichTextList ou "cellContent" du Selector pour afficher des items dans ta liste, tu peux poser des balises html
Code: Tout sélectionner
<FONT SIZE="18" COLOR="#000000"><B>blabla


- mes accents de mes titres de news sont transformés en caractères asiatiques ou carrés, est-il possible de forcer l'encodage ?

je sais pas, dsl, Ariel ?

- comment faire un lien sur un élément d'une liste liée à un connector/selector ?

peux tu être plus précis stp ? décris moi vraiment ce que tu veux faire

#20 ariels

    Ceinture Marron

  • Silex Lab
  • PipPipPipPipPipPip
  • 137 messages

Posté 14 October 2009 - 13:35 PM

Salut,
pour les problèmes d'encodage, ça peut venir de différents endroits. Ca peut être la police qui n'a pas les caractères, le flux qui se fait modifier en route... Par contre si t'as un flux d'exemple je veux essayer de m'en servir pour voir ou ça plante. C le moment, fais la pub de ton site!
ariel

#21

  • Guests

Posté 19 October 2009 - 00:01 AM

Bonsoir Ariels,

La source de mon Selector qui me pose problème (accents qui sautent) :
http://www.spirit-of...nt.com/forum/sy ... =y&xml=xml
ou
http%3A%2F%2Fwww.spirit-of-paint.com%2Fforum%2Fsyndicate.asp%3Fmethod%3Dlast_post%26results%3D30%26cid%3D9%26su%3D30%26ld%3Dy%26xml%3Dxml

d'autant plus étrange que pour les 2 autres sources, c'est OK : pas de souci

Merci d'avance pour le coup d'oeil expert...
CéD

PS : pour mes histoires de lien sur un click sur un élément d'une liste, cela fonctionne maintenant

#22

  • Guests

Posté 19 October 2009 - 00:45 AM

Bon, toujours sur le même thème... utilisation RSS

J'ai donc mis en place mes 2 images affichant mes 2 flux sur le onRollOver... mais je cherche à à avoir les 2 comportements différents, suivant mes sources RSS :
- sur une j'aimerais afficher <b><<title>></b><<content:encoded>> et ne pas activer les liens
- sur les autres j'aimerais afficher <<title>> et activer les liens

alors, j'ai essayé de m'inspirer de la doc OOF, mais en vain... J'ai tenté la syntaxe suivante, sur l'action de mon image :
onRollOver Selector_RSS.formName=http%3A%2F%2Fgfyparis.wordpress.com%2Fcategory%2FNews%2Ffeed
onRollOver Selector_RSS.selectedFieldNames=<<title>><<content:encoded>>
onRollOver Selector_RSS.getRecords
cela ne semble avoir aucun effet... :evil: :cry:

Quelqu'un pourrait m'aider sur ce point,
CéD

#23 _lex

  • Moderateur
  • PipPipPipPipPipPipPipPip
  • 1016 messages

Posté 19 October 2009 - 16:46 PM

salut
regarde http://oof.sourceforge.net/api-v1/ , dans "DataUsers > DataSelector"
pour changer ce qui est affiché, c'est "cellFormat" qu'il faut changer, pas "selectedFieldNames"
et pour activer les liens... je ne suis pas sur, tu peux me montrer le feed? il y a surement un tag pour le texte sans html et un pour le texte avec.
les listes peuvent interpreter le html ou pas, c'est le parametre "html" qui détermine le comportement



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)

authorised training centre

Centre de Formation Mediabox - Adobe et Apple Authorised Training Center.

Déclaré auprès de la Direction du Travail et de la Formation Professionnelle

Mediabox : SARL au capital de 62.000€ - Numéro d'activité : 11 75 44555 75 - SIRET : 49371646800035

MEDIABOX, 23, rue de Bruxelles, 75009 PARIS

FFP