Forums Développement Multimédia

Aller au contenu

problème à l'installation : test_file_system_rights.php

CMS Silex

7 réponses à ce sujet

#1

  • Guests

Posté 02 July 2009 - 11:21 AM

Bonjour,

je tente d'installer Silex sur un serveur LAMPP sur linux (ubuntu), et je rencontre un problème de droits (à priori) :

Warning: chmod() [function.chmod]: Op?ration non permise in /home/www/silex.declik.org.v1.5RC2/install/test_file_system_rights.php on line 21

J'ai essayé, comme indiqué, de créer le fichier conf/pass.php, et là c'est encore pire :


Fatal error: Uncaught exception 'Zend_Log_Exception' with message '"/home/www/silex.declik.org.v1.5RC2//logs/20090702silex.log" cannot be opened with mode "a"' in /home/www/silex.declik.org.v1.5RC2/cgi/library/Zend/Log/Writer/Stream.php:66 Stack trace: #0 /home/www/silex.declik.org.v1.5RC2/cgi/includes/logger.php(47): Zend_Log_Writer_Stream->__construct('/home/www/silex...') #1 /home/www/silex.declik.org.v1.5RC2/cgi/includes/server_config.php(22): logger->logger('server_config') #2 /home/www/silex.declik.org.v1.5RC2/index.php(53): server_config->server_config() #3 {main} thrown in /home/www/silex.declik.org.v1.5RC2/cgi/library/Zend/Log/Writer/Stream.php on line 66


Merci d'avance si vous pouvez m'éclairer !!!

le site est visible à l'adresse http://silex.declik.org .

Edit : je précise que j'ai effectué un chmod -R 755 /home/www/silex.declik.org.v1.5RC2

#2 Pol - Silex

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 178 messages

Posté 02 July 2009 - 11:24 AM

Hello

a priori aucune contre-indication à Silex sur Linux - bien au contraire d'ailleurs !

J'averti les spécialistes !!

Pol

#3

  • Guests

Posté 02 July 2009 - 11:27 AM

ah, j'ai réussi à aller plus loin, après un chmod 777.

là , ça a l'air de marcher ... mais le 777 je suis pas fan !! :-))

#4 Pol - Silex

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 178 messages

Posté 02 July 2009 - 11:43 AM

Je comprends

Je crois qu'il y a tout de même une autre voie !

Je te tiens au courant

Pol

#5 ariels

    Ceinture Marron

  • Silex Lab
  • PipPipPipPipPipPip
  • 137 messages

Posté 02 July 2009 - 11:56 AM

Bonjour Denis,
merci pour l'info. Comme dit Pol, ça devrait bien se passer avec Linux, d'ailleurs ça se passe bien avec les hébergeurs mutualisés. C'est étonnant qu'il te faille mettre ça en 777. C'est un serveur dédié que tu as? Chez qui?
Ariel

#6

  • Guests

Posté 02 July 2009 - 12:04 PM

c'est un RPS de chez OVH.

le serveur et LAMPP tournent très bien par ailleurs (www.declik.org par exemple est sur la même machine, c'est juste un autre vhost, et il n'y a pas de souci dessus !)

#7

  • Guests

Posté 09 July 2009 - 01:54 AM

J'ai aussi le même problème avec 1.5RC3.
Je suis sur mon propre serveur xampp sur arch linux.
En fait httpd tourne sous l'utilisateur 'nobody', j'ai donc changé récursivement le propriétaire du répertoire silex pour qu'il soit possédé par 'nobody' (chown -R nobody silex-dir).
J'ai pu ensuite continuer l'installation.

#8 ariels

    Ceinture Marron

  • Silex Lab
  • PipPipPipPipPipPip
  • 137 messages

Posté 17 July 2009 - 11:27 AM

merci pour l'info!



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)