Forums Développement Multimédia

Aller au contenu

XML + cache = problème

PAO Flash

  • Vous ne pouvez pas répondre à ce sujet
Aucune réponse à ce sujet

#1 AQUOIBON

    Ceinture Verte

  • Members
  • PipPipPipPip
  • 64 messages

Posté 25 November 2009 - 17:25 PM

Bonjour,

Le problème de la mise en cache des XML est récurrents et j'ai trouvé des astuces pour (en principe) le déjouer.

Problème, ça ne marche pas !

voici à peut-près mon code :


//1 - je charge mon XML :

monXML.load(fichierXML+"?nocache="+(new Date()).getTime()); // fichierXML = variable définissant l'adresse du fichier XML


//2 - je modifie mon XML en un créant un nouveau

nouveauXML = new XML();
... ;
nouveauXML.sendAndLoad(scriptSAUVEGARDE+"?nocache="+(new Date()).getTime(),nouveauXML); // scriptSAUVEGARDE = variable définissant l'adresse du PHP enregistrant le XML


//3 - je recharge mon XML en repassant par la phase 1) (monXML.load(fichierXML+"?nocache="+(new Date()).getTime())<img src='http://flash.mediabox.fr/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' />
 

Et Flash me ressort invariablement l'ancien XML (sauf si je vide le cache de mon navigateur) alors que le nouveau est bel et bien sauvé !! :( :( :(

En fait cela ce produit une fois sur deux :
- lorsque je fais une seconde modif Flash m'affiche le XML que j'appellerais n°1 (le n°0 étant celui de base, celui de départ quoi !);
- lorsque je fais une troisième modif, il m'affiche le XML n°2;
- ...

Help me PLEEEAAASE !



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)