Forums Développement Multimédia

Aller au contenu

Menu qui s'ouvre avec lien animé à l'intérieur

CODE Actionscript

4 réponses à ce sujet

#1 goonpay

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 112 messages

Posté 03 October 2008 - 10:48 AM

Salut tout le monde.

Voila, je suis en train de réaliser un menu, qui, au premier abord me semble peu complexe mais pour moi qui n'y connait pas grand chose en code et en organisation au sein de flash, je me sens perdu.

Explications :

J'ai un menu qui est caché dans une sorte de languette qui se déroule au passage du curseur et repart quand le curseur n'est plus au dessus. Pour ca , aucun probleme, ca marche bien.

Le souci, c'est que cette languette doit contenir plusieurs liens (qui seront des pages / séquences du flash). Ces liens, je veux leur donner une petite animation pour que le visiteur captent sur quel bouton ils se trouvent.
Et c'est la que ca se complique car, je n'arrive pas à créer cette animation quand on passe le curseur sur le lien. J'ai tenté d'utiliser la même méthode que l'ouverture de la languette mais ca ne marche pas ...

Je vous met en piece jointe le menu et croise les doigts d'avoir une réponse rapide vu l'état de panique et d'urgence dans lequel je suis icon_biggrin.gif

Fichier(s) joint(s)

  • Fichier joint  test.fla   343 Ko   14 téléchargement(s)

Modifié par Goonpay, 03 October 2008 - 10:49 AM.


#2 goonpay

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 112 messages

Posté 03 October 2008 - 14:24 PM

J'ai tenté de placer l'anim du bouton sur ma scene principale.

Ainsi, au passage sur le bloc gris, l'animation du bouton apparait et suit le menu. La, je me dis, tadam, c'est bon...

Mais non ...

Parce que du coup, lorsque je parametre l'animation du clip / bouton du menu même au moment du RollOver ou du RollOut et que je repasse sur le bloc deroulant, ca relance l'animation.

En fait, j'ai l'impression qu'il considere que quand je suis sur le clip correspondant au bouton, je ne suis plus sur le bloc ... et donc, en repassant sur le bloc, il relance l'animation...

#3 goonpay

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 112 messages

Posté 03 October 2008 - 15:47 PM

Je continue mes recherches, j'ai épluché pas mal de liens trouvés sur le forum comme :


http://www.senocular.com/flash/tutorials/buttoncapturing/

http://flash.mediabox.fr/index.php?showtop...&hl=hittest

Et voila, j'en arrive au résultat suivant :

Ma languette se déplie bien au survol. Mon clip / bouton effectue l'anim en fonction du passage du curseur dessus mais... justement, au moins petit mouvement de souris, hyper sensibilité, ca se relance etc...

Y'a une solution ?

Je joins encore le fichier

Fichier(s) joint(s)

  • Fichier joint  test_4.fla   207 Ko   15 téléchargement(s)


#4 goonpay

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 112 messages

Posté 03 October 2008 - 16:24 PM

Je continue mon processus et je note que si je place un gotoAndStop sur une image de mon bouton, aucun soucis. C'est vraiment si je fais une petite animation.
Et j'aimerais vraiment trouver le moyen de faire une petite animation. En fait, au final, j'aurais un lien texte a la place du bloc de couleur et j'aurais aimé le voir continuellement tremblotter le temps que le visiteur a le curseur dessus.

Une idée ?


#5 goonpay

    Ceinture Marron

  • Members
  • PipPipPipPipPipPip
  • 112 messages

Posté 05 October 2008 - 18:33 PM

toujours pas de réponses ?



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)