Forums Développement Multimédia

Aller au contenu

SWFobject et flash à 100%: alignement à droite bug sur Firefox

PAO Flash

6 réponses à ce sujet

#1 daviddarx

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 242 messages

Posté 22 September 2007 - 19:01 PM

Bonjour tout le monde!

Voici le contexte de mon problème:
J'ai un flash qui occupe tout le navigateur en fullscreen via SWF object. Un element du flash s'aligne à droite via un ecouteur Stage.onResize.

Vous pouvez voir l'exemple ici.

Tout marche nickel partout sauf sur Firefox ou il y a le problème suivant:

Lorsque la fenetre du navigateur atteint une taille inférieure à 900 px (la taille de la fenetre est indiquée dans l'élément aligné à droite), l'élment de droite ne s'aligne plus correctement à droite...

J'ai essayé pas mal de réglages différents dans flash mais rien n'y fait...

Avez vous déjà eu ce genre de problème? Une petite idée de la source du problème? (swf object, as, etc)
Avez vous une solution qui est compatible avec swfObject??

Merci beaucoup pour vos réponses!
++!

PS: les sources (très courtes) en zip sont jointe au post...

Fichier(s) joint(s)

  • Fichier joint  test.zip   1.15 Mo   37 téléchargement(s)

Modifié par b-one, 22 September 2007 - 19:02 PM.


#2 daviddarx

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 242 messages

Posté 23 September 2007 - 16:24 PM

sorry l'exemple est

#3 julien

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 429 messages

Posté 24 September 2007 - 09:27 AM

Salut,

Je suis sous ff et je n'ai aucun problème à une taille inférieur à 900px (ton code n'as pas l'air non plus d'avoir de lacune) quelle version ff as tu ?

#4 Attraktive Medias

  • Members
  • PipPipPipPipPipPipPipPip
  • 1602 messages

Posté 24 September 2007 - 09:33 AM

pas de pb chez moi non plus wink.gif
Attraktive Medias
Développement Multimedia

#5 daviddarx

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 242 messages

Posté 24 September 2007 - 09:50 AM

Salut!
Merci pour vos réponses, elles m'ont été utiles!

Après tests sur plusieurs machines et plusieurs versions de firefox, il s'avère que ce n'est que ma configutation de firefox qui fait foirer le script...

Tous mes posts sont en effet installés avec les extensions suivantes: 1 skin, stumbleupon, webdevlopper, tidy html, google sync.

J'ai essayé sur des postes vierges de tous addons et ca marche nickel... Je ferai des tests bientot pour savoir quel est l'addon qui fait bugger le swfobject, apparement... ou le flash player.


Vous tiens au courant, ca peut être intéressant de voir si il y a d'autres problpmes connus avec l'addon...

Merci
++

#6 julien

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 429 messages

Posté 24 September 2007 - 09:53 AM

En tout cas ce n'est pas webdeveloper vu que je l'ai aussi icon_mrgreen.gif

#7 daviddarx

    Ceinture Noire

  • Members
  • PipPipPipPipPipPipPip
  • 242 messages

Posté 24 September 2007 - 11:59 AM

Après test, il s'agit de l'addon "stumbleupon", qui bug lorsque il est placé dans la barre de statut, en bas du navigateur.
J'avais déjà eu des problème avec cet addon dans cette position précise, sur PC notamment.

Placé en haut du navigateur, il ne pose plus de problème.

Merci pour votre participation!

++

bone



1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)