Forums Développement Multimédia

Aller au contenu

Contenu de Xari

Il y a 14 élément(s) pour Xari (recherche limitée depuis 19-August 18)


Filtrer par type de contenu

Voir pour ce membre

#1151636 Slider comparatif entre deux images ✔

Posté par Xari sur 17 October 2012 - 23:15 PM in Développement Actionscript

Ah oui, je n'avais pas pensé au masque d'écrêtage alors que je l'utilise tout le temps sur Photoshop :P !

Merci bien, c'est parfait !



#1151634 Slider comparatif entre deux images ✔

Posté par Xari sur 17 October 2012 - 21:49 PM in Développement Actionscript

Bonjour !

J'ai réalisé un petit slider très simple qui me permet de comparer deux images.
Le seul problème c'est que les images se superposent et ce n'est donc pas très pratique pour vraiment voir la différence entre les deux.

En gros je déplace une des deux images sur l'autre en fonction de la position de mon curseur grâce à une "barre" de défilement.

Le seul problème c'est que lorsque que ma barre est au milieu de mon slider. Je me retrouve avec à gauche de la barre la partie gauche de l'image 1 et à droite de la barre, la partie gauche de l'image 2.

Ce que je voudrais c'est avoir la partie gauche de l'image 1 à gauche de ma barre et la partie DROITE de l'image 2 à droite de ma barre.

Si vous avez des idées je suis preneur !

Voilà un petit schéma pour mieux comprendre :

Image IPB


et mon code actuel :

import flash.events.MouseEvent;
import fl.motion.MotionEvent;
stage.addChild(s1);
stage.addChild(s2);
stage.addChild(barre);

barre.addEventListener(MouseEvent.MOUSE_DOWN, enfoncé)
barre.addEventListener(MouseEvent.MOUSE_UP, relaché)

function relaché(ev:MouseEvent):void{
stage.removeEventListener(MouseEvent.MOUSE_MOVE, drag);
}

function enfoncé(ev:MouseEvent):void{
stage.addEventListener(MouseEvent.MOUSE_MOVE, drag);
}

function drag(me:MouseEvent):void {
s2.x=mouseX;
barre.x=mouseX-3;
}
 


Merci d'avance :) !



#1148533 Animation non conforme à la prévisualisation

Posté par Xari sur 13 August 2012 - 21:52 PM in Développement Actionscript

Bah zut alors ! Je le vois bien affiché sur le forum, par contre sur mon PC en local, ça ne fonctionne tjrs pas :(. peut etre un probleme avec le player alors !

Merci encore ^^.



#1148528 Animation non conforme à la prévisualisation

Posté par Xari sur 13 August 2012 - 20:55 PM in Développement Actionscript

Bonjour !

J'ai quelques problèmes avec mon petit projet flash actuel.
J'ai fini mon projet et le résultat me plait quand je lance l'exportation dans flash (avec ctrl+entrée) le seul problème c'est que quand j'exporte mon résultat je n'ai pas du tout le même résultat, et pour cause plus rien ne fonctionne je n'ai qu'une vulgaire image et un bouton fantôme.

Je ne comprends pas du tout pourquoi la prévisualisation dans Flash ne correspond pas avec mon Export, si quelqu'un pouvait m'éclairer :o ?

Ci-joint mon .fla pour que ça soit plus compréhensible. Fichier joint  animation_sand_king.fla   1.37 Mo   6 téléchargement(s)

Merci d'avance !



#1147992 précharger des vidéos sur un .swf

Posté par Xari sur 01 August 2012 - 11:40 AM in Animer avec Flash

Re !
Je vois le genre, mais le problème c'est que j'aimerais tout charger avant le début de l'animation en fait. Car faire attendre l'utilisateur à chaque vidéo n'est vraiment pas souhaitable :(. Je préfère qu'il attende plus longtemps mais une seule fois ^^.



#1147987 précharger des vidéos sur un .swf

Posté par Xari sur 01 August 2012 - 10:47 AM in Animer avec Flash

Bonjour à tous !

J'ai quelques problèmes avec mon animation flash, je travaille sur un petit projet pour un guide de jeu, l'idée est simple, j'ai représenté la carte du jeu en petit, et en cliquant sur des boutons je fais apparatire en vidéo le personnage se mouvant en jeu.

Chaque bouton est donc associé à une vidéo en .mp4 pesant jusqu'à 800ko.
En local, tout fonctionne très bien, par contre dès que j'exporte mon animation flash, et que j'héberge mes vidéos sur mon serveur ftp, lors du lancement de la vidéo, celle-ci se "charge" et provoque donc un effet très saccadé.

J'aimerais savoir comment remédier à cela... Y-a-t-il un moyen de charger toutes mes vidéos avant le début de l'animation en laissant un petit loader qui s'enlève une fois que l'animation est "prête" ?
Ou peut être une meilleure solution ?

Merci d'avance :).



#1139611 [AS3] Bouton qui lance une vidéo (.flv) ✔

Posté par Xari sur 04 February 2012 - 20:24 PM in Développement Actionscript

A supprimer, bêtise de ma part !



#1139592 [AS3] Bouton qui lance une vidéo (.flv) ✔

Posté par Xari sur 04 February 2012 - 14:22 PM in Développement Actionscript

Bonjour,

merci beaucoup !
Grâce à ton exemple, j'ai réussi à faire ce que je voulais ! C'est parfait :P.



#1139577 [AS3] Bouton qui lance une vidéo (.flv) ✔

Posté par Xari sur 04 February 2012 - 01:22 AM in Développement Actionscript

Re-bonsoir,

tout d'abord merci pour ton aide : ) !


Alors j'ai quelques questions :

► Quand tu dis "à l'intérieur tu rajoutes le clip "ecran" il y a une manipulation à faire ou c'est juste histoire de dire que les deux clips sont superposés sur la scène ?
► Pour le chemin de la vidéo que je veux lire, je peux prendre un chemi absolu ? Avoir ça par exemple :
 unFlux.play("C:\Users\blabla\Desktop\vid.flv");

► J'ai repris ton code dans les grandes lignes malheureusement, quand je compile, j'obtiens ça :
TypeError: Error #1034: Echec de la contrainte de type : conversion de flash.display::MovieClip@2879b0b1 en flash.media.Video impossible.
        at flash.display::Sprite/constructChildren()
        at flash.display::Sprite()
        at flash.display::MovieClip()
        at bara_flash_v3_fla::MainTimeline()


En tout cas je suis déjà plus éclairé sur la question ^^.



#1139570 [AS3] Bouton qui lance une vidéo (.flv) ✔

Posté par Xari sur 03 February 2012 - 22:44 PM in Développement Actionscript

Bonsoir !

Je suis débutant en flash, mais j'ai de bonnes connaissances en programmation (java/C++)


Je cherche à faire un truc qui me parait simple, mais pourtant je n'arrive pas à me renseigner comment faire.
Je souhaite faire un bouton qui, lorsqu'on clique dessus, fait apparaitre une vidéo à un endroit donné sur mon animation, la vidéo est ensuite automatiquement jouée, puis lorsque la vidéo est terminée, elle disparait.

J'ai essayé d'importer directement un .flv dans ma bibli, puis d'utiliser tant bien que mal un FLVPlayback mais je n'ai pas vraiment compris comment cela fonctionnait ^^'.
J'ai également essayé de faire un MovieClip contenant ma vidéo, mais là encore, je suis vite bloqué. De plus en faisant comme ça l'animation mettait très longtemps à se charger :/.

Alors quand je positionne mon FLVPlayback au départ, lorsque je lance l'animation, la vidéo est bien jouée, mais je voudrais qu'elle ne soit jouée que si j'appuie sur le bouton et ensuite, quand la vidéo s'arrête, il reste un carré grisé à l'endroit de la vidéo, j'aimerais qu'il disparaisse également ^^.

Si vous pouviez juste me donner des pistes à creuser : ).

Merci d'avance !.



#1139184 [AS3] Récupérer l'instance ou le nom du bouton qui a été cliqué ✔

Posté par Xari sur 29 January 2012 - 13:21 PM in Développement Actionscript

Re, finalement, j'ai gardé mes boutons pour le moment, en fait au lieu de récupérer le "label" j'ai récupéré le "name" donc l'instance du bouton, pour savoir quel bouton avait été cliqué ^^.

Cependant l'utilisation des MovieClips permet beaucoup plus de choses, je les utiliserais surement pour mon prochain travail !



#1139180 [AS3] Récupérer l'instance ou le nom du bouton qui a été cliqué ✔

Posté par Xari sur 29 January 2012 - 11:20 AM in Développement Actionscript

D'accord je vais regarder ça, merci : ).
Bon dimanche aussi :P.



#1139177 [AS3] Récupérer l'instance ou le nom du bouton qui a été cliqué ✔

Posté par Xari sur 29 January 2012 - 11:05 AM in Développement Actionscript

Wuuuut, quel idiot xD...

Bon, il n'y a plus d'erreur sur ça, par contre, quand je lance et que je clique sur un bouton j'ai ça :

ReferenceError: Error #1069: La propriété label est introuvable sur flash.display.SimpleButton et il n'existe pas de valeur par défaut.
 

Je me doute que ya un problème avec currentTarget.label, quand je fais un "ctrl + espace" a la fin de currentTarget. il ne me propose pas "label" donc je supose que ce n'est pas possible de récupérer le label ?



#1139173 [AS3] Récupérer l'instance ou le nom du bouton qui a été cliqué ✔

Posté par Xari sur 29 January 2012 - 10:46 AM in Développement Actionscript

Bonjour à tous !

Je suis nouveau en Flash, et notamment en AS3 mais j'ai des connaissances dans la programmation (java/C etc...)

Mon problème est le suivant :

J'ai une scène avec plusieurs boutons et je souhaiterais que chaque bouton appelle une et une seule fonction qui redirige ensuite vers une autre fonction selon le bouton qui a été cliqué.

C'est pas très clair alors voilà mon code :


bouton_icone.addEventListener(MouseEvent.CLICK, jouer);
bouton_charge.addEventListener(MouseEvent.CLICK, jouer);
function jouer(evt:MouseEvent):void
{
switch (event.currentTarget.label)
{
  case "btn_icone" :
  sonicone.play();
  break;

  case "btn_charge" :
  soncharge.play();
  break;
}
 

Donc j'utilise event.currentTarget.label pour récupérer le label du bouton qui a été cliqué, pour ensuite faire un switch qui me permet de faire l'action correspondant au clic de ce bouton. Le problème c'est qu'avec ce code je déclenche une erreur :

1120 : Access of undefined property event.
sur la ligne
"switch (event.currentTarget.label)"

Je ne comprends donc pas pourquoi et je fais appel à vos lumières !


Autre question qui me permettrai d'éviter ça : est ce que je peux sur un addEventListener appeler une fonction avec paramètres ?

Exemple :

au lieu d'avoir :

bouton_icone.addEventListener(MouseEvent.CLICK, jouer);
...
function jouer(evt:MouseEvent):void

je veux avoir un truc du genre :

bouton_icone.addEventListener(MouseEvent.CLICK, jouer(1));
...
function jouer(evt:MouseEvent, nombre:int):void
 

j'appelle jouer avec comme paramètre d'entrée un int, qui me permet de distinguer quel bouton a appellé la fonction, ce qui règle mon problème.
Mais je n'ai pas réussi a faire un appel d'une telle fonction... Peut être une mauvaise syntaxe ?

Merci d'avance : ) !